Hi all, I try to set my prisma environment with n...
# prisma-whats-new
Hi all, I try to set my prisma environment with node boilerplate-advanced but when i try
yarn start
I've this issue
Copy code
Maxime SCIBETTA@DESKTOP-Q30836P MINGW64 ~/Documents/s-cool
$ yarn start
yarn start v0.21.3
$ nodemon -e js,graphql -x node -r dotenv/config src/index.js
[nodemon] 1.14.11
[nodemon] to restart at any time, enter `rs`
[nodemon] watching: *.*
[nodemon] starting `node -r dotenv/config src/index.js`
      throw er; // Unhandled 'error' event

Error: listen EADDRINUSE :::4000
    at Object._errnoException (util.js:1022:11)
    at _exceptionWithHostPort (util.js:1044:20)
    at Server.setupListenHandle [as _listen2] (net.js:1351:14)
    at listenInCluster (net.js:1392:12)
    at Server.listen (net.js:1476:7)
    at C:\Users\Maxime SCIBETTA\Documents\s-cool\node_modules\graphql-yoga\dist\src\index.js:241:34
    at new Promise (<anonymous>)
    at GraphQLServer.start (C:\Users\Maxime SCIBETTA\Documents\s-cool\node_modules\graphql-yoga\dist\src\index.js:232:16)
    at Object.<anonymous> (C:\Users\Maxime SCIBETTA\Documents\s-cool\src\index.js:20:8)
    at Module._compile (module.js:643:30)
[nodemon] app crashed - waiting for file changes before starting...
maybe your localhost:4000 is already in use. You may want to kill that process.
Yes, the error indicates the port is already used. You can specify a different port in your server options
Thanks !
yarn start
works now on port 8000 but when i do
yarn dev
i've the same issues with port 3000.... why
clearly because you did the same commands in another shell before 🙂
lsof -i -P -n | grep 3000
to find the process id using port
kill <pid>
to kill that process