Nexus
05/08/2025, 9:10 AMyonidavidson
05/11/2025, 10:50 AMyonidavidson
05/11/2025, 10:50 AMssrdive
05/14/2025, 6:12 AMJeroen Rinzema
05/14/2025, 8:22 AMRaman
05/19/2025, 7:53 AMRaman
05/19/2025, 7:56 AMAmir
05/20/2025, 8:32 AMdefault for targetless run.: 400 Bad Request (ErrorResponse { status: "Failure", message: "Cannot find namespace default for targetless run.", reason: "400 Bad Request", code: 400 })
at mirrord/cli/src/connection.rs:112
Error: × mirrord operator API failed: creating a websocket connection failed with
│ ApiError: Cannot find namespace default for targetless run.: 400 Bad
│ Request (ErrorResponse { status: "Failure", message: "Cannot find
│ namespace default for targetless run.", reason: "400 Bad Request", code:
│ 400 })
but i gave it a namespace this is my mirrord config
{
"feature": {
"network": {
"incoming": "mirror",
"outgoing": true
},
"fs": "read",
"env": true
},
"operator": false,
"agent": {
"namespace": "dev-amir-prompt"
},
"target": {
"namespace": "dev-amir-prompt"
}
}Whites
05/26/2025, 12:38 PMcurl requests to the remote endpoint, I only get about 1/2 of them in my local service.
Can it be because the deployment has 2 replicas?
This is how I run mirrord
mirrord exec --steal --no-remote-dns --no-outgoing --agent-log-level debug -n <my namespace> -a <my namespace> --target deployment/<my deployment>/container/<my container> -- <my command here>Kiran Kumar
06/11/2025, 1:45 PMKiran Kumar
06/11/2025, 1:46 PMSora
06/11/2025, 1:49 PMAmir
06/24/2025, 8:31 AMBrad
07/18/2025, 6:03 AM{
"timestamp": "2025-07-18T05:54:45.794723Z",
"level": "ERROR",
"fields": {
"error": "io error: Address already in use (os error 98)"
},
"target": "mirrord_agent::entrypoint",
"span": {
"args": "Args { mode: Ephemeral { mesh: None }, communicate_port: 51234, communication_timeout: 360, network_interface: None, metrics: None, test_error: false, operator_tls_cert_pem: None, is_mesh: true, ipv6: false }",
"name": "start_agent"
},
"spans": [
{
"args": "Args { mode: Ephemeral { mesh: None }, communicate_port: 51234, communication_timeout: 360, network_interface: None, metrics: None, test_error: false, operator_tls_cert_pem: None, is_mesh: true, ipv6: false }",
"name": "start_agent"
}
],
"threadId": "ThreadId(1)"
}
I don't have ttl set, but I do have
communication_timeout: 360
startup_timeout: 360
Will these keep the agent alive? Or is there a recommended way to make this work? ThanksBrad
07/21/2025, 7:17 AMbacktrack5r3
10/30/2025, 1:20 PMbacktrack5r3
10/30/2025, 8:40 PMinstrument.sh and I am wondering if there is any workaround to make it work.
Thanks in advance 🙏K3RN3L_P4N1C
11/20/2025, 4:53 PMshell
2025-11-20T16:38:20.099316Z ERROR ThreadId(02) operator::shared_session_watcher: 108: mirrordclustersessions watch stream encountered an error error=watch stream failed: ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): storage is (re)initializing: TooManyRequests
2025-11-20T16:39:10.078007Z WARN ThreadId(02) operator::mutated_pods_cleanup_controller: 205: pods watch stream encountered an error error=watch stream failed: Error reading events stream: ServiceError: error reading a body from connection: Error reading events stream: ServiceError: error reading a body from connection: ServiceError: error reading a body from connection: error reading a body from connection: peer closed connection without sending TLS close_notify: https://docs.rs/rustls/latest/rustls/manual/_03_howto/index.html#unexpected-eof
2025-11-20T16:39:10.095030Z WARN ThreadId(02) operator::workload_patch_request_controller: 415: mirrordclusterworkloadpatchrequests watch stream encountered an error error=watch stream failed: Error reading events stream: ServiceError: error reading a body from connection: Error reading events stream: ServiceError: error reading a body from connection: ServiceError: error reading a body from connection: error reading a body from connection: peer closed connection without sending TLS close_notify: https://docs.rs/rustls/latest/rustls/manual/_03_howto/index.html#unexpected-eof
2025-11-20T16:39:10.096672Z WARN ThreadId(02) operator::copied_pods_controller: 172: pods watch stream encountered an error error=watch stream failed: Error reading events stream: ServiceError: error reading a body from connection: Error reading events stream: ServiceError: error reading a body from connection: ServiceError: error reading a body from connection: error reading a body from connection: peer closed connection without sending TLS close_notify: https://docs.rs/rustls/latest/rustls/manual/_03_howto/index.html#unexpected-eof
2025-11-20T16:39:10.107676Z WARN ThreadId(02) operator::agent_pods_controller: 178: pods watch stream encountered an error error=watch stream failed: Error reading events stream: ServiceError: error reading a body from connection: Error reading events stream: ServiceError: error reading a body from connection: ServiceError: error reading a body from connection: error reading a body from connection: peer closed connection without sending TLS close_notify: https://docs.rs/rustls/latest/rustls/manual/_03_howto/index.html#unexpected-eof
2025-11-20T16:39:10.111854Z WARN ThreadId(02) operator::workload_patch_controller: 245: mirrordclusterworkloadpatches watch stream encountered an error error=watch stream failed: Error reading events stream: ServiceError: error reading a body from connection: Error reading events stream: ServiceError: error reading a body from connection: ServiceError: error reading a body from connection: error reading a body from connection: peer closed connection without sending TLS close_notify: https://docs.rs/rustls/latest/rustls/manual/_03_howto/index.html#unexpected-eof
I completely uninstalled the operator from the cluster and reinstalled it, but that didn’t resolve the issue. It looks like some kind of “too many requests” error. Could this be coming from the Kubernetes API server?
Technical information:
• Kubernetes: 1.31.4
• Mirrord-Operator: 3.130.0
• Mirrord: 3.173.2K3RN3L_P4N1C
11/20/2025, 4:54 PMbradschwartz
12/03/2025, 7:55 PMbradschwartz
01/09/2026, 7:24 PMmirrord operator status), and trying to start a new session continuously fails with a 403 on upgrading connection to be over Websockets:
mirrord operator API failed: creating a websocket connection failed with failed to upgrade to a WebSocket connection: failed to switch protocol: 403 Forbidden
I'm using my admin role so i can port-forward/create-pods/etc. Any tips on what this could be?K3RN3L_P4N1C
01/13/2026, 10:14 AM2026-01-13T10:06:45.161892Z ERROR ThreadId(02) operator::workload_patch_request_controller: 494: mirrordclusterworkloadpatchrequests watch stream encountered an error error=failed to perform initial object list: ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): storage is (re)initializing: TooManyRequests
2026-01-13T10:06:45.198122Z ERROR ThreadId(02) operator::shared_session_watcher: 262: mirrordclustersessions watch stream encountered an error error=watch stream failed: ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): storage is (re)initializing: TooManyRequests
2026-01-13T10:06:45.216294Z INFO ThreadId(01) operator_service: 726: Shutting down probe and OpenAPI server to start full API
2026-01-13T10:06:45.217852Z ERROR ThreadId(02) operator::external_resources_controller: 292: mirrordclusterexternalresources watch stream encountered an error error=watch stream failed: ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): storage is (re)initializing: TooManyRequests
2026-01-13T10:06:45.283038Z INFO ThreadId(01) operator_service: 737: Starting full API server
2026-01-13T10:06:45.988932Z ERROR ThreadId(02) operator::workload_patch_request_controller: 494: mirrordclusterworkloadpatchrequests watch stream encountered an error error=failed to perform initial object list: ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): storage is (re)initializing: TooManyRequests
2026-01-13T10:06:47.624663Z ERROR ThreadId(02) operator::shared_session_watcher: 262: mirrordclustersessions watch stream encountered an error error=failed to perform initial object list: ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 }): storage is (re)initializing: TooManyRequests
Is this related to our cluster or indicates a problem in our setup ?K3RN3L_P4N1C
01/13/2026, 10:14 AM2026-01-13T10:07:12.674016Z WARN ThreadId(02) operator_kube_utils::list_retry: 28: Failed to list mirrordpolicies, retrying... error=ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 })
2026-01-13T10:07:12.880635Z WARN ThreadId(02) operator_kube_utils::list_retry: 28: Failed to list mirrordclusterpolicies, retrying... error=ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 })
2026-01-13T10:07:13.205928Z WARN ThreadId(02) operator_kube_utils::list_retry: 28: Failed to list mirrordtlsstealconfigs, retrying... error=ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 })
2026-01-13T10:07:13.443006Z WARN ThreadId(02) operator_kube_utils::list_retry: 28: Failed to list mirrordclustertlsstealconfigs, retrying... error=ApiError: storage is (re)initializing: TooManyRequests (ErrorResponse { status: "Failure", message: "storage is (re)initializing", reason: "TooManyRequests", code: 429 })
Here are the specs
Kubernetes Version: v1.34.3
Mirrod Agent version: 3.180.0
Operator Helm chart: 1.43.0backtrack5r3
01/21/2026, 4:15 PMbacktrack5r3
01/29/2026, 4:18 PMmirrordConfig
Any idea ?
Thanks in advance !
https://cdn.discordapp.com/attachments/950020257156833340/1466467437594546308/message.txt?ex=697cd9ba&is=697b883a&hm=0da207c0194da16c8229a53aa5085f30f55103dfae7c5f261e71946e916774cd&
https://cdn.discordapp.com/attachments/950020257156833340/1466467438106378280/image.png?ex=697cd9ba&is=697b883a&hm=5ebe3987357012e439f5d43be11d98238bff9b85c2b833d8dd9a47dd96426c68&Baune8D
02/04/2026, 9:02 AMDaniel
03/16/2026, 8:30 PMPaws
04/15/2026, 1:28 PMmirrord error: Failed to execute authentication command specified in kubeconfig: No such file or directory (os error 2) (VSCode) Haven't changed a bit of my kubeconfig. Any ideas?Paws
04/15/2026, 1:44 PMaws being alone in the config. I had to change it to command: /usr/local/bin/aws. That's strange because I know that wasn't touched for agesPaws
04/17/2026, 9:00 AM