https://facebook.com/groups/graphql-kr logo
#잡담
Title
# 잡담
u

이찬희

06/03/2020, 12:07 PM
pnpm 이야기가 나와서 질문이 있어요. 사용해신 분들 중에
pnpm을 지원하지 않는 패키지
가 있는 경우 직접 해결해보신 분 계신가요? pnpm을 지원하지 않는 경우는 대부분 라이브러리(패키지)에 의존성이 잘못 적혀있는 케이스였어요.
(graphql 질문은 아니니까 질문 채널 아니어도 괜찮겠죠?)
h

Hyeseong Kim

06/03/2020, 12:17 PM
pnpm을 "지원하지 않는" 패키지는 없고요
말씀하시는 경우는
implicit transive peer dependencies 문제인 것 같은데 이건 npm 생태계의 고질적인 문제에요
그냥 해당 패키지가 매니페스트를 잘못쓴거니까 PR 열면 됩니다
yarn 2 릴리즈 이후로 이슈화가 되서 요즘은 많이들 고친 편입니다 (관리되고 있는 라이브러리라면)
뭐 yarn 덕분에 다들 저 문제를 무시 못하게 됐다면서 pnpm 개발자들이 농담반으로 좋아하고 그랬었죠
ohh 1
저도 덕분에 이삭좀 많이 주웠고 ㅋㅋ
u

이찬희

06/03/2020, 12:29 PM
오홍 그렇군요. 다음에 주울 기회가 있으면 주워봐야겠어요 ㅋㅋ 감사합니다.
zzzz 1