We are trying to upgrade our project from dbt-core...
# community-support
f
We are trying to upgrade our project from dbt-core to dbt fusion. We are on version
0.25.0
of Elementary and the dbt package seems to be working fine 🎉 . We also use the
edr
CLI python package, but this tends to give us some trouble. So far our setup has been that we install all dbt related dependencies in a single virtualenv. When we tried to upgrade our
requirements.txt
into something like:
Copy code
dbt==2.0.0rc196
elementary-data==0.25.0
The issue I have is that when I call
dbt --version
it shows me:
Copy code
dbt --version
Core:
  - installed: 1.11.12
  - latest:    1.11.12 - Up to date!
This is not my intended behaviour I would have liked. I was wondering what the Elementary team has in mind to work around these kind of issues? (I understand there are ways around above issue, but just wanted to have the input how the Elementary team would recommend doing it)
🎫 1
Could someone from the Elementary <!subteam^S08HYBWCF6E> please take a look at this request? Some simple pointers to what the teams suggestion would be adds a lot of value for us
n
Hey @Frank Tubbing [Beequip] , we'll check it out 🙏🏼
🙌 1
Hey @Frank Tubbing [Beequip], wanted to let you know that we should release a new CLI that will take care of this later this week 💪
o
Hi @Noya Offer, was this fixed in CLI 0.26 version? I tried it today with 0.26 and ran into the same issues that it's still pulling the dbt-core dependency
👀 1
p
Hey @Ondra Paul! We'll need to deploy a small fix on our end for the logic we used, we're on it!
🙌 1