rapid-book-98432
04/21/2022, 2:03 PMroot@vmi741747:~# kubectl logs datahub-elasticsearch-setup-job-cc2lq
2022/04/21 131735 Waiting for: http://elasticsearch-master:9200
2022/04/21 131736 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1s
2022/04/21 131738 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1s
2022/04/21 131740 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1s
2022/04/21 131742 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1s
2022/04/21 131744 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1s
2022/04/21 131746 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1s
2022/04/21 131748 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1s
2022/04/21 131750 Problem with request: Get http://elasticsearch-master:9200: dial tcp 10.103.69.1779200 connect: connection refused. Sleeping 1sAnd then failing. If you have any idea i'm open to heard. Thanks again !
square-activity-64562
04/21/2022, 2:11 PMkubectl get pods -n NAMESPACErapid-book-98432
04/21/2022, 2:24 PMNAME READY STATUS RESTARTS AGE
datahub-elasticsearch-setup-job-4mqw8 0/1 Error 0 20m
datahub-elasticsearch-setup-job-ffbrq 0/1 Error 0 24m
datahub-elasticsearch-setup-job-fqjg9 0/1 Error 0 28m
datahub-elasticsearch-setup-job-mzfrh 0/1 Error 0 18m
datahub-elasticsearch-setup-job-n2ktz 0/1 Error 0 16m
datahub-elasticsearch-setup-job-tnlq9 0/1 Error 0 22m
datahub-elasticsearch-setup-job-trwbr 0/1 Error 0 26m
elasticsearch-master-0 0/1 Running 0 32m
elasticsearch-master-1 0/1 Pending 0 32m
elasticsearch-master-2 0/1 Pending 0 32m
prerequisites-cp-schema-registry-6f4b5b894f-7d4nw 2/2 Running 0 32m
prerequisites-kafka-0 1/1 Running 1 (32m ago) 32m
prerequisites-mysql-0 1/1 Running 0 32m
prerequisites-neo4j-community-0 1/1 Running 0 32m
prerequisites-zookeeper-0 1/1 Running 0 32m
square-activity-64562
04/21/2022, 2:25 PMrapid-book-98432
04/21/2022, 3:15 PMrapid-book-98432
04/21/2022, 3:16 PM"stacktrace": ["org.elasticsearch.discovery.MasterNotDiscoveredException: null",
"at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$2.onTimeout(TransportMasterNodeAction.java:297) [elasticsearch-7.16.2.jar:7.16.2]",
incalculable-ocean-74010
04/21/2022, 3:22 PMincalculable-ocean-74010
04/21/2022, 3:27 PMThree Kubernetes nodes to respect the default "hard" affinity settings)
Since you are deploying on minikube you have a 1-node cluster.
Unless you specified differently with:
minikube start --nodes 3 (or more)
Elasticsearch will fail to launch.
In case you haven’t it very likely means that elasticsearch deployment was not able to create the 3 replicas across different nodes.rapid-book-98432
04/21/2022, 5:39 PMincalculable-ocean-74010
04/21/2022, 5:41 PMrapid-book-98432
04/21/2022, 5:42 PMrapid-book-98432
04/21/2022, 5:43 PMrapid-book-98432
04/21/2022, 6:26 PMincalculable-ocean-74010
04/21/2022, 7:23 PMrapid-book-98432
04/21/2022, 7:34 PMrapid-book-98432
04/21/2022, 7:40 PMrapid-book-98432
04/21/2022, 7:40 PM{"type": "server", "timestamp": "2022-04-21T193858,506Z", "level": "ERROR", "component": "o.e.b.ElasticsearchUncaughtExceptionHandler", "cluster.name": "elasticsearch", "node.name": "elasticsearch-master-0", "message": "uncaught exception in thread [main]",
"stacktrace": ["org.elasticsearch.bootstrap.StartupException: ElasticsearchException[failed to bind service]; nested: AccessDeniedException[/usr/share/elasticsearch/data/nodes];",
incalculable-ocean-74010
04/21/2022, 10:31 PMrapid-book-98432
04/22/2022, 6:19 AMincalculable-ocean-74010
04/22/2022, 9:30 AMrapid-book-98432
04/22/2022, 10:13 AMrapid-book-98432
04/22/2022, 10:14 AMrapid-book-98432
04/22/2022, 10:15 AMError: rendered manifests contain a resource that already exists. Unable to continue with install: PodDisruptionBudget "elasticsearch-master-pdb" in namespace "default" exists and cannot be imported into the current release: invalid ownership metadata; annotation validation error: key "meta.helm.sh/release-name" must equal "helm-es-minikube": current value is "elasticsearch"I can try to add more disk to minicube ?
incalculable-ocean-74010
04/22/2022, 12:40 PMrapid-book-98432
04/22/2022, 12:53 PMrapid-book-98432
04/22/2022, 12:59 PMrapid-book-98432
04/22/2022, 12:59 PMrapid-book-98432
04/22/2022, 1:18 PM```extraInitContainers:
- name: file-permissions
image: busybox
command: ['chown', '-R', '1000:1000', '/usr/share/elasticsearch/']
volumeMounts:
- mountPath: /usr/share/elasticsearch/data
name: elasticsearch-master
securityContext:
privileged: true
runAsUser: 0```
Finaly add this in values.yaml
for the ES deployment
rapid-book-98432
04/22/2022, 1:18 PMrapid-book-98432
04/22/2022, 1:27 PMincalculable-ocean-74010
04/22/2022, 2:20 PMincalculable-ocean-74010
04/22/2022, 2:20 PMrapid-book-98432
04/27/2022, 9:44 AMrapid-book-98432
06/16/2022, 7:07 AM