[main] WARN org.apache.kafka.clients.ClientUtils -...
# all-things-deployment
s
[main] WARN org.apache.kafka.clients.ClientUtils - Couldn't resolve server prerequisites-kafka:9092 from bootstrap.servers as DNS resolution failed for prerequisites-kafka [main] ERROR io.confluent.admin.utils.cli.KafkaReadyCommand - Error while running kafka-ready. org.apache.kafka.common.KafkaException: Failed to create new KafkaAdminClient at org.apache.kafka.clients.admin.KafkaAdminClient.createInternal(KafkaAdminClient.java:499) at org.apache.kafka.clients.admin.Admin.create(Admin.java:73) at org.apache.kafka.clients.admin.AdminClient.create(AdminClient.java:49) at io.confluent.admin.utils.ClusterStatus.isKafkaReady(ClusterStatus.java:138) at io.confluent.admin.utils.cli.KafkaReadyCommand.main(KafkaReadyCommand.java:150) Caused by: org.apache.kafka.common.config.ConfigException: No resolvable bootstrap urls given in bootstrap.servers at org.apache.kafka.clients.ClientUtils.parseAndValidateAddresses(ClientUtils.java:89) at org.apache.kafka.clients.ClientUtils.parseAndValidateAddresses(ClientUtils.java:48) at org.apache.kafka.clients.admin.KafkaAdminClient.createInternal(KafkaAdminClient.java:455) ... 4 more I don’t know why it happens
e
Hi @steep-soccer-91284, how are you deploying DataHub?
s
I’m deploying to AWS EKS, using 3 of t3.large instances.
Thank you for response, It appeared our problem.
e
Glad to hear it @steep-soccer-91284!
👍 1