nice-country-99675
12/30/2021, 12:13 PMpipeline = Pipeline.create(
{
"source": {
"type": source,
"config": {
"username": f"{conn.login}",
"password": f"{conn.password}",
"database": f"{conn.schema}",
"host_port": f"{conn.host}:{conn.port}",
"database_alias": alias,
"env": "PROD",
"schema_pattern": {
"deny": deny_schemas
},
},
},
"transformers": transformers,
"sink": {
"type": "datahub-rest",
"config": {"server": f"{datahub.host}"},
},
}
)
pipeline.run()
pipeline.raise_from_status()
The thing is the DAG ends with
{local_task_job.py:154} INFO - Task exited with return code Negsignal.SIGKILL
It's the only thing that is actually logged.... it seems it fails as soon as the process starts. At first, I thought it was a memory issue, we increase the pods memory, and now we are pretty far from the memory limit. It even fails when I ran dray_run. Locally it's working fine.
Locally I'm using Airflow 2.2.2 while in production I'm using Airflow 2.2.1. I would really appreciate any suggestion...helpful-optician-78938
01/03/2022, 5:58 PMnice-country-99675
01/04/2022, 2:19 PMboundless-eye-52199
05/09/2022, 8:07 AMairflow dags test {DAG_ID} {EXEC_DATE}
it succeeded. However, if I run DAG in standard way, then it is killed everytime. @helpful-optician-78938 @nice-country-99675helpful-optician-78938
05/09/2022, 4:58 PMdazzling-judge-80093
05/09/2022, 5:14 PMprehistoric-room-17640
06/09/2022, 10:35 AM