Hi Team, happy new year - I'm trying to create a d...
# ingestion
g
Hi Team, happy new year - I'm trying to create a datahub-mae-consumer docker container via yml - https://github.com/linkedin/datahub/blob/master/docker/docker-compose.consumers.yml - but received the error: *************************** APPLICATION FAILED TO START *************************** Description: Field systemAuthentication in com.linkedin.metadata.kafka.config.EntityHydratorConfig required a bean of type 'com.datahub.authentication.Authentication' that could not be found. The injection point has the following annotations: - @org.springframework.beans.factory.annotation.Autowired(required=true) - @org.springframework.beans.factory.annotation.Qualifier(value=systemAuthentication) Action: Consider defining a bean of type 'com.datahub.authentication.Authentication' in your configuration. 2022/01/03 163547 Command exited with error: exit status 1
h
@big-carpet-38439, could you please take a look at this?
👍 1
g
@big-carpet-38439 - follow the container log
Guys, tks for this help
b
@gentle-florist-49869 What is the version? I believe there was an affected version - 0.8.17 i believe
That this error shows up in for standalone consumers
g
acryl-datahub, version 0.8.17.4
@big-carpet-38439 yes, is for stadalone MCE/MAE consumers because I would like to get easier metrics from kafka streams
but if exist another way I can explore too
because MCE is working fine in my lab here from http://localhost:9090/actuator/metrics but MAE Consumer not , because docker container is error and exit
@big-carpet-38439 anyway to try to fix this please?
b
Are you consuming via Helm ?
My recommendation is to bump to 0.8.21 if you're able to 🙂
g
@big-carpet-38439 today in my lab I'm using via docker , is it exit one away to upgrade version bu docker please?
b
Are you using
datahub docker quickstart
to run?
g
yes
datahub docker quickstart --quickstart-compose-file ./docker/quickstart/docker-compose.quickstart.yml
@big-carpet-38439 datahub docker quickstart --quickstart-compose-file ./docker/quickstart/docker-compose.quickstart.yml
@big-carpet-38439 when you use datahub docker quickstart not created specific container to MAE/MCE consumers, right? because I'm looking for this point to see metrics (kafka streams) for exemple in MAE consumer endpoint http://localhost:9091/actuator/metrics
b
Yes correct! When you use quickstart we will not start standalone consumers
So you'd need to use a particular quickstart file for starting standalone consumers
g
@big-carpet-38439 yes, I used the yml file to create standalone consumers but MAE showing error above - Do you have any idea to try solve please?
b
Yes - you can upgrade acryl-datahub package to the latest
Copy code
python3 -m pip install --upgrade acryl-datahub
Then we can check the version
And then do another quickstart
g
@big-carpet-38439, tks and I will try this and back here with results 🙂
@big-carpet-38439,I did the acryl upgrade and new quickstart and after standalone consumer but MAE show the same error
*************************** APPLICATION FAILED TO START *************************** Description: Field systemAuthentication in com.linkedin.metadata.kafka.config.EntityHydratorConfig required a bean of type 'com.datahub.authentication.Authentication' that could not be found. The injection point has the following annotations: - @org.springframework.beans.factory.annotation.Autowired(required=true) - @org.springframework.beans.factory.annotation.Qualifier(value=systemAuthentication) Action: Consider defining a bean of type 'com.datahub.authentication.Authentication' in your configuration. 2022/01/04 191010 Command exited with error: exit status 1
Datahub
DataHub CLI version: 0.8.21.0 Python version: 3.9.7 (default, Sep 10 2021, 145943) [GCC 11.2.0]
b
Can you paste the full command you have run?
Want to try to reproduce this locally
g
sure
@big-carpet-38439 docker-compose -p datahub -f /home/fabiocastro/datahub/docker/docker-compose.yml -f /home/fabiocastro/datahub/docker/docker-compose.override.yml -f /home/fabiocastro/datahub/docker/docker-compose.consumers.yml up -d
b
perfect
thank you
g
tks you too
@big-carpet-38439 how are you? Did you have chance to try reproduce the error, please?
b
yes - followed up in the other thread