great-branch-515
08/30/2022, 7:46 AMError while executing config command with args '--command-config /tmp/connection.properties --bootstrap-server <http://b-3.testdatahub.kbb3mi.c14.kafka.us-west-2.amazonaws.com:9094,b-2.testdatahub.kbb3mi.c14.kafka.us-west-2.amazonaws.com:9094,b-1.testdatahub.kbb3mi.c14.kafka.us-west-2.amazonaws.com:9094|b-3.testdatahub.kbb3mi.c14.kafka.us-west-2.amazonaws.com:9094,b-2.testdatahub.kbb3mi.c14.kafka.us-west-2.amazonaws.com:9094,b-1.testdatahub.kbb3mi.c14.kafka.us-west-2.amazonaws.com:9094> --entity-type topics --entity-name _schemas --alter --add-config cleanup.policy=compact'
java.util.concurrent.ExecutionException: org.apache.kafka.common.errors.UnknownTopicOrPartitionException:
at org.apache.kafka.common.internals.KafkaFutureImpl.wrapAndThrow(KafkaFutureImpl.java:45)
at org.apache.kafka.common.internals.KafkaFutureImpl.access$000(KafkaFutureImpl.java:32)
at org.apache.kafka.common.internals.KafkaFutureImpl$SingleWaiter.await(KafkaFutureImpl.java:104)
at org.apache.kafka.common.internals.KafkaFutureImpl.get(KafkaFutureImpl.java:272)
at kafka.admin.ConfigCommand$.getResourceConfig(ConfigCommand.scala:552)
at kafka.admin.ConfigCommand$.alterConfig(ConfigCommand.scala:322)
at kafka.admin.ConfigCommand$.processCommand(ConfigCommand.scala:302)
at kafka.admin.ConfigCommand$.main(ConfigCommand.scala:97)
at kafka.admin.ConfigCommand.main(ConfigCommand.scala)
Caused by: org.apache.kafka.common.errors.UnknownTopicOrPartitionException:
Can anyone help?