Hi. Was the problem get resolved? We are also faci...
# all-things-deployment
c
Hi. Was the problem get resolved? We are also facing similar issue with our self-signed secured elastic search.
Copy code
java.io.IOException: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
	at org.elasticsearch.client.RestClient.extractAndWrapCause(RestClient.java:884) ~[elasticsearch-rest-client-7.10.2.jar!/:7.10.2]
	at org.elasticsearch.client.RestClient.performRequest(RestClient.java:283) ~[elasticsearch-rest-client-7.10.2.jar!/:7.10.2]
	at org.elasticsearch.client.RestClient.performRequest(RestClient.java:270) ~[elasticsearch-rest-client-7.10.2.jar!/:7.10.2]
We are deploying Datahub on GKE. The cert files are mounting to the pod and we are setting all envrionment variable described here Same configurations worked well for 0.9.2. However, after upgrading to 0.10.1, we are seeing errors like above. (Also tried 0.9.6.1, same errors)