some-actor-27079
08/31/2023, 9:07 PMdatahub-datahub-system-update-job which keeps on failing.
If I modify the prerequisites and the datahub values.yaml as suggested here:
https://github.com/acryldata/datahub-helm/issues/347
This is:
"""
Filling values in prerequisites:
cp-helm-charts:
enabled: true
cp-schema-registry:
enabled: true
and values in datahub:
kafka:
schemaregistry:
type: KAFKA
url: "<http://datahub-datahub-gms:8080/schema-registry/api/>"
"""
I am able to helm install the prerequisites without issues. I am also able to helm install datahub. However, in the front-end I don't have an "Ingestion" tab. If I write "http:my-datahub.domain/ingestion" I get an error "Failed to load ingestion sources! An unexpected error occurred" (see image). If I try to ingest some data, I get another error: "Unauthorized to perform this action. Please contact your DataHub administrator (code 403)." (see image).
Does anyone have any clue on how to fix these errors?
Any tips would be greatly appreciated!aloof-gpu-11378
09/01/2023, 6:53 AMbitter-author-2524
09/01/2023, 8:04 PMMANAGE_INGESTION permission.some-actor-27079
09/04/2023, 2:21 PMdatahub-datahub-system-update-job keeps failing after several attempts. The pod's logs with the error look like the attached file:
update-job-logs.txt
Now, in this github issue:
https://github.com/acryldata/datahub-helm/issues/347
I think they find the same error when installing with the helm chart 0.2.181 (one version ealier). They suggest the following modification to the values.yaml as a workaround:
"""
Same problem.
Filling values in prerequisites:
cp-helm-charts:
enabled: true
cp-schema-registry:
enabled: true
and values in datahub:
kafka:
schemaregistry:
type: KAFKA
url: "<http://prerequisites-cp-schema-registry:8081>"
Still does not work, and same error. So documentation is incomplete and not enough for deploy on kubernetes.For me exactly this config worked and the switch between the registries worked without an recognizable issue so far. """ When applying these suggestions, we are able to deploy to AKS without errors. We would like the implications of modifying kafka's schemaregistry from type INTERNAL to type Kafka, as well as of enabling the cp-schema-registry in the prerequisites...