Hello Everyone, I need to make Business Glossary a...
# all-things-deployment
f
Hello Everyone, I need to make Business Glossary available for my local Datahub instance. The current version is v0.8.34 so Glossary is not here. So the question is if I follow the official updating docs of Datahub (https://datahubproject.io/docs/advanced/no-code-upgrade/) would my data, metadata, lineage, domains, ingestions deleted?
plus1 1
l
Hey there 👋 I'm The DataHub Community Support bot. I'm here to help make sure the community can best support you with your request. Let's double check a few things first: 1️⃣ There's a lot of good information on our docs site: www.datahubproject.io/docs, Have you searched there for a solution? 2️⃣ It's not uncommon that someone has run into your exact problem before in the community. Have you searched Slack for similar issues?
f
I mean I saw about Docker Compose Deployments - Preserve Data. But when I run
run_upgrade.sh
script located under
docker/datahub-upgrade/nocode it gives me a error
The default "docker.env" file located in datahub/docker/datahub-upgrade/env is completely different than "docker-compose-without-neo4j.quickstart.yml" file located in datahub/docker/quickstart
a
your data won’t be deleted, it will run a reindex job though
You’re on a pretty old version- is there an option to upgrade?
f
@astonishing-answer-96712 I actually could not make an upgrade. There is a run_upgrade.sh script but its not working
@astonishing-answer-96712 I kinda made a lot of research on Datahub-upgrade. But I must be missing out something. Do you have any idea how to upgrade v0.8.34 to v0.10.1?
a
You should just be able to run datahub-upgrade and it should handle things
f
But when im running datahub-upgrade it keeps getting stuck at error Caused by: java.lang.RuntimeException: Request cannot be executed; I/O reactor status: STOPPED
a
Ah ok, this might be due to an architecture issue-I saw someone was helping you out in another thread- is that the same problem?
f
oh yeah, it was the same problem but im still stuck at the same situation. not sure what to do
a
a docker system prune might help here, what is your deployment environment?