We have some lucee servers using a MySQL database....
# lucee
m
We have some lucee servers using a MySQL database. We recently updated the database from 5.6 to 5.7. We will be updating to 8.0 at some point this year. We have some error messages related to the database and in the error there is an 'additional' section that shows the query that was run, and some other information. I've seen these kinds of errors before. The messages show the DatabaseVersion as 5.6 still. I'm wondering where that information comes from. Would restarting the lucee servers cause them to show the correct version? I'm pretty sure they were restarted already after the update.
It has been a few days since we did the database update
d
Do you have to change the compatibility mode of the database? I've basically been in the SQL Server world for 25+ years, so I'm not well versed in MySQL, but in SQL Server each database has a compatibility mode that you would also need to update in order for the actual database to be running in the latest database mode.
m
Yeah there might be something that isn't fully updated yet. The database is a MySQL database hosted at Azure. It is just a service, we didn't setup the server ourselves. And to update it there was just an update button we clicked, so I'm not sure if anything else needs to be done.
w
if you run SELECT VERSION() from a cfquery does it report that correctly?
d
m
@dswitzer Oh yeah. That could be related.
d
It looks like Azure does not return the correct version and it's a known issue.
m
I'm still checking to see what I get if I run a query to get version()
It probably doesn't matter, I was just concerned that it could be an issue, but I'll look into those issues you found some more.
z
which version of the mysql extension are you running?
m
The extension is version 8.0.28 and lucee version 5.3.8.206. Also when I do SELECT version() I get the correct version back.
z
could you share the actual error?
👍 1
m
The most common one is 'Unknown thread id: 64750'. The number is different in different ones. It seems to happen when a query takes too long.
z
yeah, i've seen that one, i think it's resolved by the 8.0.30 mysql jdbc driver
m
Ok thanks. I'm planning to update that extension and lucee soon so hopefully things will be good after that. It seems like the incorrect MySQL version is an Azure issue so I don't know if that will be fixed but it doesn't seem to cause any issues for now