Anyone ever run into `Empty reply from server`when...
# box-products
Anyone ever run into `Empty reply from server`when using CommandBox?
When running with
Copy code
[ERROR] io.undertow.request: UT005071: Undertow request failed HttpServerExchange{ GET /}
java.lang.NoClassDefFoundError: Could not initialize class org.xnio.channels.Channels
@bdw429s any ideas?
Found, trying to use a previous java 8 version, still not working. Getting an error
No matching function for [ENCODEFORURL] found
Are you sure you're on a newer java version?
Show me how you tried to change it
Encodeforurl missing is an unrelated lucee bug
Forget the server
It probably died halfway through starting and didn't install all the extensions
@bdw429s, yes, we're operating on Java jre1.8.0_331
used the
server set jvm.javaVersion=openjdk8_jdk8u322-b06
(as stated in the article above)
I think that's actually the bad one
The encodeforurl was indeed solved by re-initializing the server (forget & start)
the 331 is the bad one triggering the issues
I'm on my phone right now, but it was thinking update 312 or so was the previous version
The 322-b06 actually works
Even more strange, 331 works on my machine, but not on my colleague's machine 🙂 . Total mindf*ck.
That's not the command on the article above
The actual command in the article is
server set jvm.javaVersion=openjdk8_jdk8u312-b07
I know.
I just looked at it and the command I provided was for update 312, so I'm not sure where you got 322 from
So it's working for you now?
I changed it to 322, b/c i knew this version also existed.
Yes, we got it to work, but I'm still surprised b/c of the inconsistent behavior between our two machines.
Even though we're using the same installed JRE (1.8.0_331) and same commandbox version (5.4.2+00453) (on Windows 10 btw).
Brb, got to pick up my daughter from school.