The VS Code extension team got me past some initia...
# adobe
The VS Code extension team got me past some initial issues with the plugin, but I'm running into some issues with using the debugger. I'll start a thread, and anyone else who's hitting issues (or wants to help me with my problems! 🙂 can jump in)
so that part at least is ok
anyone have suggestions on what to try?
the only things I can think of are maybe my server settings themselves aren't quite right. I have the server added and it shows a green dot, making me think it's configured right and can see that the server is up
I left the document root value as the default, though I don't know what "document root" really means. This isn't the path to the root directory for my project. Not sure if that matters.
I just don't have anything at all. I read the plugin's pdf documentation on this part, and did not understand what to add, or even whether it was necessary
my setup is that we have CF at C:\ColdFusion2018, and the git repo for the project at C:\code\isr, with it running in a docker container that maps volumes like
Copy code
      # web root (includes home, include, directories)
      - "c:/code/isr/wwwroot/:/app"
To make debugger work, several server settings have to be turned on. Hold on, lemme find the line in the docs...
Did you add
-Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005
to your JVM settings and restart, replacing 5005 with whatever port you are using?
@Rodney I didn't. I didn't see that mentioned in the pdf. I can give that a try
I'm maybe trying it a bit before I should 🙂
I got it to work, with minimal functionality, by doing what Mark said and adding that JVM setting.
I think there's some parts of debugger that aren't quite running right, but it SHOULD work for things like breakpoints, watch, etc.
oh, gotcha - I was thinking it was meaning "isn't working at all yet" kind of thing
ok, I did not have the enable request debugging output checked. I'll see if that does the trick
No, no... I'm wracking my brain trying to remember what particular thing was being dumb. I think there's a bug where the debugger process will not stop properly and then trying to debug will summon a dark lord of the underworld or something.
Remember to restart CF after making the changes (I DEFINITELY didn't do that the first time lol)
yup - restarting now
I know I gave up on the debugger in the eclipse version a couple years ago, just because it would work ok (usually) until you changed a source file and then it would just cease stopping on breakpoints or evaluating expressions until you restarted CF again. just too painful.
legend level meme right thar
That meme... within a meme
I have enable request debug output checked, allow line debugging checked, and - I'm not actually seeing a checkbox for RDS. Do you know which panel that's on?
ugh..... only, because it's docker, "enable request debugging output" is unchecked again after startup. I might have to mess around w/ my docker compose file and see if I can get it to tick that for me when it makes the container
AH, yeah that would do it. It has to start with that enabled I think.
I'm messing around with a .cfconfig.json file and adding a key (I totally made up, but guessing it might be right?):
hmm - nope. broke down and read the manual. It's
k, with
set to
in my
file, a docker compose down and back up has CF Admin showing that box checked on server startup, so that's good now. I'm still getting the same error notifications, though
hmm. might ping support again, I literally have next to no experience spinning up Docker. One of the gaps in my experience I'm afraid.
gotcha - yeah, my docker chops are equivalent to a frontend dev copy/pasting jQuery code from stack overflow and hoping for the best. 😄
would it be best to file a bug or just reply to the email the team sent me about the other issue I'm past now?
I'd email CFSUP with this issue and reference the previous engagement, so if the team you worked with is still available they can maybe pick it up. Mention who you were working with on the previous ticket.
gotcha - I ended up just doing a reply on the email they'd sent before. If I don't hear back I'll email cfsup
I'm seeing that the "enable request debugging output" option being checked seems to barf a lot of debugging content at the end of all responses, so it renders on all pages I load, including when I have a tiny modal dialog that loads its markup via ajax. Suddenly that tiny dialog is taller than the viewport and it's no longer easy to tell if I have layout issues with my UI or if it's just because of the stream of consciousness CF is favoring me with. I don't need or want to see that in the UI, especially if the debugger works and I can inspect things from there to debug. It would be tremendously nice to not have that enabled if it's possible to have the debugger work without it.
maybe that's a change request I can/should file in the bug tracker
Does the debugger still work if you put
setting showDebugOutput=false;
at the top of your page?
no, but only because I haven't yet gotten the debugger to work under any circumstances 🙃 If I can get it to work, I'll give that a go though
for now, I'm seeing if I can just display: none the thing with a user stylesheet bwahaha