I'm getting the following error on my dev server b...
# cfml-general
b
I'm getting the following error on my dev server but I can't seem to find a reason and the interwebs haven't been much help. It's running ACF2021 dev edition on Windows The referenced file/path doesn't exist, but it doesn't exist on the working production server either. I've checked the mail settings in CF Admin and examined the /lib/neo-mail.xml for anomalies and didn't find any. Does anyone have any ideas where else to look? "Can't find resource for base name coldfusion/tagext/mail/resource.properties"
d
Left field possibility, is the Mail package installed in dev? I don't actually know if that's the error you'd get or not.
b
Just checked. Yes it is, but nice thought!
👍 1
b
That's one of the few results I found and it didn't get me anywhere. But thanks for the thought!
j
More left field stuff, an IIS mapped folder?
e
Posting the full error would be helpful, but where are some generic items. 1 disable the 8dot3 namespace creation, windows does weird stuff with this: fsutil.exe behavior set disable8dot3 1, Enable long path support, edit the registry, add these Dword values if not present and then reboot: "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\LongPathsEnabled = 1 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Policies\LongPathsEnabled = 1" -- Lastly, whatever folder you have placed your wwwroot, make sure that the user for the service has full permissions to that folder path. Right-click on the top level folder (ie, c:\Coldfusion2021\ or whatever), go to properties, security, and either make sure your IISUSR and CFUSR have full control or give everyone "full control". Try it again; if that continues to fail, then be enable to audit for file permissions for IIS and your ColdFusion instance.
g
Copy code
reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\ /v LongPathsEnabled /t REG_DWORD /d 1

reg add HKEY_LOCAL_MACHINE\System\CurrentControlSet\Policies\ /v LongPathsEnabled /t REG_DWORD /d 1
b
So far, no joy. But thanks for all of the suggestions! @Evil Ware The message I posted was from the mail.log file. Would there be a more detailed message elsewhere?
This is what I find in the exception.log: "Error","scheduler-0","04/30/24","142113","","Can't find resource for base name coldfusion/tagext/mail/resource.properties" java.util.MissingResourceException: Can't find resource for base name coldfusion/tagext/mail/resource.properties at coldfusion.util.RB.loadProperties(RB.java:193) at coldfusion.util.RB.<init>(RB.java:125) at coldfusion.util.RB.getMessage(RB.java:623) at coldfusion.util.RB.getString(RB.java:343) at coldfusion.mail.MailSpooler.processFile(MailSpooler.java:2516) at coldfusion.mail.MailSpooler.retrieveSpoolMail(MailSpooler.java:2427) at coldfusion.mail.MailSpooler.access$500(MailSpooler.java:120) at coldfusion.mail.MailSpooler$SpoolerSoftCache.fetch(MailSpooler.java:2864) at coldfusion.util.SoftCache.get_statsOff(SoftCache.java:153) at coldfusion.util.SoftCache.get(SoftCache.java:92) at coldfusion.mail.MailSpooler.retrieveMail(MailSpooler.java:2333) at coldfusion.mail.MailSpooler.sendMail(MailSpooler.java:1299) at coldfusion.mail.MailSpooler.deliverStandard(MailSpooler.java:1769) at coldfusion.mail.MailSpooler.run(MailSpooler.java:1734) at coldfusion.scheduling.ThreadPool.run(ThreadPool.java:260) at coldfusion.scheduling.WorkerThread.run(WorkerThread.java:71)
e
I would re-verify your install. In Java, that error means you're missing a jar/file.. Perhaps an update or something went off with a file utility and corrupted a file or two.
d
Is CF fully up to date? There was a period a bit ago where CF didn't resolve its own dependencies correctly, loaded an older version of some packages, on some servers and not others. That bit me and a few others, most people were ok, but the latest updates fixed it. Symptoms weren't exactly this, but conceptually it's similar, CF can't find its own stuff. If you're up to date, I'd either ping Adobe support, or reinstall CF.