I've got a Lucee instance running on the `5.4.0.80...
# lucee
j
I've got a Lucee instance running on the
5.4.0.80-light
docker image. Initially, I get this in the logs:
Hmm, trying to reproduce it to see when it happens.
z
you have the zip resource provider still enabled?
j
yeah, i added it to this image after seeing the error above. i still got the error after that but now i'm unable to reproduce the error. trying to verify that the error is truly gone.
is the admin known to require the compress tags extension, by the way?
z
it doesn't, however, it requires the zip provider as configured by default
6 logs out an error when not available
j
maybe i don't know about a "zip provider." i only know about the "compress tags" extension.
so what's the "zip provider" you mentioned?
z
lucee has resource providers, like file, http, zip, s3 etc google em
👍 1
ftp and so on
j
i'm having trouble finding out how to enable/disable resource providers in lucee. google is failing me.
z
look at the lucee-seerver.xml
lots of stuff here at the bottom https://docs.lucee.org/categories/files.html
j
This message contains interactive elements.
quick tangent: what's the relationship between, say, the s3 resource provider and the s3 extension?
z
there's a dummy provider which throws an error unless it's installed
👍 1
j
do the zip resource provider and the compress tags extension have the same relationship?
z
nope, as i said
we currently bundle commons-compress which does all that, it;s 2mb... it's facing eviction possibly
👍 1
j
fwiw, i can't reproduce my original exception, which i guess is a good thing.
r
Remember that intermittent ESAPI extension issue I had @zackster? I wonder is there's a trend of extension issues with 5.4.0.80?
z
this one is unrelated IMHO
r
Fair enough, just saying 🙂
z
always worth asking!
that error, for example, looks like the admin simple hadn't had enough time to deploy yet, patience
🆗 1