Hey, we're just working on setting up Yatai on AWS EKS with AWS RDS PostreSQL database.
While following the setup guide (
https://docs.yatai.io/en/latest/installation/yatai.html), we encountered some issues.
• Error: migrate up db: cannot create migrate: pq: no pg_hba.conf entry for host "123.456.123.123" (placeholder ip), user "yatai", database "yatai", no encryption
We got around this by setting the --sslmode=verify-all flag.
But now we're encountering a new SSL-related issue:
• error: migrate up db: cannot create migrate: tls: failed to verify certificate: x509: certificate signed by unknown authority
How are we supposed to correctly set up Yatai with AWS RDS PostreSQL? While following the steps, we are encountering these issues. Any insights would be very helpful! 🙂
EDIT (Solution):
Solved issue by setting sslmode=require.