This message was deleted.
# ask-for-help
s
This message was deleted.
j
Hey! could you share your error message, and the yatai version that you are using?
u
Sure! • Yatai installation command:
Copy code
helm upgrade --install yatai yatai \
    --repo <https://bentoml.github.io/helm-charts> \
    -n yatai-system \
    --set postgresql.host=$PG_HOST \
    --set postgresql.port=$PG_PORT \
    --set postgresql.user=$PG_USER \
    --set postgresql.database=$PG_DATABASE \
    --set postgresql.password=$PG_PASSWORD \
    --set postgresql.sslmode=$PG_SSLMODE \
    --set s3.endpoint=$S3_ENDPOINT \
    --set s3.region=$S3_REGION \
    --set s3.bucketName=$S3_BUCKET_NAME \
    --set s3.secure=$S3_SECURE \
    --set s3.accessKey=$S3_ACCESS_KEY \
    --set s3.secretKey=$S3_SECRET_KEY
• Error message:
Copy code
Error: migrate up db: cannot create migrate: pq: no pg_hba.conf entry for host "192.168.55.136", user "yatai", database "yatai", no encryption
Usage:
  yatai-api-server serve [flags]

Flags:
  -c, --config string    (default "./yatai-config.dev.yaml")
  -h, --help            help for serve

Global Flags:
  -d, --debug   debug mode, output verbose output

error: migrate up db: cannot create migrate: pq: no pg_hba.conf entry for host "192.168.55.136", user "yatai", database "yatai", no encryption
• Yatai version:
v1.1.10
• PostgreSQL version:
v15
• K8s version:
v1.25
I changed PostgreSQL version to v14 and it is working well now. I think there is a SSL/TLS issue.
j
CC: @Xipeng Guan
x
This answer might be able to solve your problem. https://dba.stackexchange.com/a/84002
u
However in aws environment, it may not provide
pg_hba.conf
file.
u
yes when i installed, I followed your documents like below:
Copy code
export PG_PASSWORD=$(kubectl get secret --namespace yatai-system postgresql-ha-postgresql -o jsonpath="{.data.password}" | base64 -d)
export PG_HOST=postgresql-ha-pgpool.yatai-system.svc.cluster.local
export PG_PORT=5432
export PG_DATABASE=yatai
export PG_USER=postgres
export PG_SSLMODE=disable
d
Hey! Was this issue resolved for PostreSQL v15? I'm running into the same problem, so if you found a solution I'd be more than happy to hear about it! 🙂
x
According to the official RDS documentation, you can modify the value of sslmode during Yatai installation. https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/PostgreSQL.Concepts.General.SSL.html#PostgreSQL.Concepts.General.SSL.Connecting
d
Okay awesome, I'm just testing this now so hopefully it works
Appreciate you - thanks!
u
Oh, i downgraded to PostgreSQL v14. is it working with v15 following upper RDS documentation?
u
I see. Thanks!