This message was deleted.
# ask-for-help
s
This message was deleted.
f
This error seems promising, but it is (afaik) impossible to grant super user rights on AWS RDS and I doubt that it is truly required by yatai either?
Copy code
pq: permission denied to create extension "pgcrypto"
Hmm after installing pgcrypto manually Im getting new errors.
Copy code
Error: migrate up db: cannot migrate up: migration failed: ALTER TYPE ... ADD cannot run inside a transaction block in line 0: ALTER TYPE "resource_type" ADD VALUE 'yatai_component';
This feels like the wrong path. What postgres version is supported by Yatai? Could it be that Aurora Serverless V1 doesnt work?
Copy code
engine                   = "aurora-postgresql"
engine_version           = "11.16"
t
@sauyon Do you know what this issue could be? I would think aurora should work. Looks like there was some type of permission problem. which was maybe resolved manually and got into a bad state on install?
s
Hm, not sure, I think maybe @Xipeng Guan would know?
f
Thanks for getting back, I’m still very interested in resolving this ❤️