Slackbot
04/19/2023, 8:07 PMbala rao
04/19/2023, 8:30 PMbala rao
04/19/2023, 8:30 PMextraServerComponents=org.apache.bookkeeper.stream.server.StreamStorageLifecycleComponentJon P
04/19/2023, 8:30 PMJon P
04/19/2023, 8:36 PMstandalone ?bala rao
04/19/2023, 8:43 PMbala rao
04/19/2023, 8:43 PMJon P
04/20/2023, 8:30 AMextraServerComponents config to standalone.conf via the environment config in my Docker Compose file results in different (more terminal!) errors
2023-04-20T08:18:34,681+0000 [main] ERROR org.apache.pulsar.PulsarStandaloneStarter - Failed to start pulsar service.
...
Caused by: java.lang.IllegalArgumentException: Invalid metadata service URI format: metadata-store:rocksdb:///pulsar/data/metadata
so I’m assuming there is more config required which I’m looking into. I tried the same with 2.10.4 and that works the same as 2.9.1, so looks like a change in 2.11.0 (also tried 2.11.1 this morning, same errors as 2.11.0).
Noticed a mention of RocksDB in the 2.11.x architecture overview for metadata storage in standalone, but struggling to find anything in the docs about enabling/configuring function state storage in a Docker standalone instance.Jon P
04/20/2023, 9:02 AMPulsarStandalone.java there’s reference to usingNewDefaultsPIP117 , which took me here. Also from the code, noticed that adding
- PULSAR_STANDALONE_USE_ZOOKEEPER=1
to my compose file means it reverts back to using ZooKeeper rather than RocksDB and I can once again query function state!Jon P
04/20/2023, 9:25 AMtopicsPattern config won’t actually subscribe to any topics and trying to get the whole lot working on an M2 Mac