This message was deleted.
# general
s
This message was deleted.
b
I believe this error has been fixed in the past by adding the following config in the bookeeper.conf
Copy code
extraServerComponents=org.apache.bookkeeper.stream.server.StreamStorageLifecycleComponent
j
Thanks! I'll give that a try
Would that also work in a local Docker container running in
standalone
?
b
I would assume so. This conversation from the past talks about this error
j
Just for info, adding the
extraServerComponents
config to standalone.conf via the environment config in my Docker Compose file results in different (more terminal!) errors
Copy code
2023-04-20T08:18:34,681+0000 [main] ERROR org.apache.pulsar.PulsarStandaloneStarter - Failed to start pulsar service.
...
Caused by: java.lang.IllegalArgumentException: Invalid metadata service URI format: metadata-store:rocksdb:///pulsar/data/metadata
so I’m assuming there is more config required which I’m looking into. I tried the same with 2.10.4 and that works the same as 2.9.1, so looks like a change in 2.11.0 (also tried 2.11.1 this morning, same errors as 2.11.0). Noticed a mention of RocksDB in the 2.11.x architecture overview for metadata storage in standalone, but struggling to find anything in the docs about enabling/configuring function state storage in a Docker
standalone
instance.
Looking in
PulsarStandalone.java
there’s reference to
usingNewDefaultsPIP117
, which took me here. Also from the code, noticed that adding
Copy code
- PULSAR_STANDALONE_USE_ZOOKEEPER=1
to my compose file means it reverts back to using ZooKeeper rather than RocksDB and I can once again query function state!
🙌 1
Now on to next problems .. why function using
topicsPattern
config won’t actually subscribe to any topics and trying to get the whole lot working on an M2 Mac