This message was deleted.
# general
s
This message was deleted.
j
https://pulsar.apache.org/charts doesn't have 2.11. it only has this:
and if i go to https://github.com/apache/pulsar-helm-chart, i see that it only holds v2.10.2
help?
n
the helm chart release process in not bound to the Pulsar versioning if you want to use Pulsar 2.11.0 you can change the image tag in your values
j
Aaah ok. Thank you.
t
Do you have some e2e tests to validate that the current Helm chart is working with Pulsar 2.11?
j
No I don't. I'm still trying to work ut how to upgrade from 2.10 to 2.11
t
This is interesting... I have my local broker in the running state even when my bookie is not ready. I checked the broker inti container (
wait-bookkeeper-ready
) logs and there is
Copy code
bookkeeper cluster is already initialized
bookkeeper cluster is ready
checking bookie init container (
pulsar-bookkeeper-verify-clusterid
) logs I see errors:
Copy code
Caused by: java.util.concurrent.ExecutionException: org.apache.bookkeeper.bookie.BookieException$MetadataStoreException: Failed to get cluster instance id
	at org.apache.bookkeeper.meta.MetadataDrivers.runFunctionWithMetadataBookieDriver(MetadataDrivers.java:355)
	at org.apache.bookkeeper.meta.MetadataDrivers.runFunctionWithRegistrationManager(MetadataDrivers.java:375)
	at org.apache.bookkeeper.tools.cli.commands.bookies.InstanceIdCommand.apply(InstanceIdCommand.java:49)
	... 4 more
Caused by: org.apache.bookkeeper.bookie.BookieException$MetadataStoreException: Failed to get cluster instance id
	at org.apache.bookkeeper.discover.ZKRegistrationManager.getClusterInstanceId(ZKRegistrationManager.java:429)
	at org.apache.bookkeeper.tools.cli.commands.bookies.InstanceIdCommand.lambda$apply$0(InstanceIdCommand.java:52)
	at org.apache.bookkeeper.meta.MetadataDrivers.lambda$runFunctionWithRegistrationManager$0(MetadataDrivers.java:378)
	at org.apache.bookkeeper.meta.MetadataDrivers.runFunctionWithMetadataBookieDriver(MetadataDrivers.java:350)
	... 6 more
Caused by: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for BookKeeper metadata
	at org.apache.bookkeeper.discover.ZKRegistrationManager.getClusterInstanceId(ZKRegistrationManager.java:419)
	... 9 more
and then the container is frozen:
Copy code
[0.165s][info ][gc,metaspace] Narrow klass base: 0x0000000800000000, Narrow klass shift: 0, Narrow klass range: 0x100000000
[2.067s][info ][safepoint   ] Safepoint "Cleanup", Time since last: 1774480000 ns, Reaching safepoint: 1621792 ns, At safepoint: 116083 ns, Total: 1737875 ns
[3.068s][info ][safepoint   ] Safepoint "Cleanup", Time since last: 1000443793 ns, Reaching safepoint: 634333 ns, At safepoint: 9500 ns, Total: 643833 ns
[4.776s][info ][safepoint   ] Safepoint "Cleanup", Time since last: 1706665376 ns, Reaching safepoint: 445583 ns, At safepoint: 10083 ns, Total: 455666 ns
[6.613s][info ][safepoint   ] Safepoint "Cleanup", Time since last: 1834859710 ns, Reaching safepoint: 2282500 ns, At safepoint: 20291 ns, Total: 2302791 ns
in the
pulsar-bookie-init
job I see:
Copy code
2023-01-27T12:15:34,434+0000 [main-SendThread(local-dxp-pulsar-zookeeper:2181)] WARN  org.apache.zookeeper.ClientCnxn - An exception was thrown while closing send thread for session 0x10000dc9fbb000b.
org.apache.zookeeper.ClientCnxn$EndOfStreamException: Unable to read additional data from server sessionid 0x10000dc9fbb000b, likely server has closed socket
	at org.apache.zookeeper.ClientCnxnSocketNIO.doIO(ClientCnxnSocketNIO.java:77) ~[org.apache.zookeeper-zookeeper-3.8.0.jar:3.8.0]
	at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350) ~[org.apache.zookeeper-zookeeper-3.8.0.jar:3.8.0]
	at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1282) ~[org.apache.zookeeper-zookeeper-3.8.0.jar:3.8.0]
2023-01-27T12:15:34,908+0000 [main] INFO  org.apache.zookeeper.ZooKeeper - Session: 0x10000dc9fbb000b closed
Exception in thread "main" com.google.common.util.concurrent.UncheckedExecutionException: org.apache.bookkeeper.bookie.BookieException$MetadataStoreException: Failed to get cluster instance id
	at org.apache.bookkeeper.tools.cli.commands.bookies.InstanceIdCommand.apply(InstanceIdCommand.java:61)
	at org.apache.bookkeeper.bookie.BookieShell$WhatIsInstanceId.runCmd(BookieShell.java:1494)
	at org.apache.bookkeeper.bookie.BookieShell$MyCommand.runCmd(BookieShell.java:246)
	at org.apache.bookkeeper.bookie.BookieShell.run(BookieShell.java:2345)
	at org.apache.bookkeeper.bookie.BookieShell.main(BookieShell.java:2436)
Environment: • Mac M1 • Docker Engine
v20.10.21
• Kubernetes
v1.25.2
bookie
POD restarts = 0 😄
this is an issue with bookie init container, once it is restarted, I see that bookie is green
j
Debugging pulsar errors is a PhD science in itself.
😄
The upgrade to 2.11 isn't as smooth as expected. Mine crashes too.
t
it looks good now, but I had to remove bookie pod and it was recreated
j
Did u start with 2.10 and then installed 2.11 directly over it?
You modified the image tags?
t
No, from the scratch.
I am checking how does it work on
amd64
vms in
GCP
.
n
before upgrading to 2.11.0 I suggest you to carefully read the release notes: https://pulsar.apache.org/release-notes/versioned/pulsar-2.11.0/#2023-01-11
👀 1
j
Oh from scratch is ok. No issues.