@channel I am getting this error after building pi...
# general
r
@channel I am getting this error after building pinot docker image and running it:
Copy code
All illegal access operations will be denied in a future release
2023/01/19 12:25:41.149 INFO [PinotAdministrator] [main] Usage: pinot-admin.sh <subCommand>
Here is the dockerFile link: https://github.com/apache/pinot/blob/master/docker/images/pinot/Dockerfile This error is because of line 66. can somebody please help me with this?
s
What is the docker run command you;re using?
r
Copy code
docker run <Image>:<Tag>
s
That's not how the pinot-admin script is supposed to work If you're trying to run all the components seperately, you'd have to run each of them seperately including zookeeper
Copy code
docker run \
    --network=pinot-demo \
    --name pinot-zookeeper \
    --restart always \
    -p 2181:2181 \
    -d zookeeper:3.5.6

docker run --rm -ti \
    --network=pinot-demo \
    --name pinot-controller \
    -p 9000:9000 \
    -e JAVA_OPTS="-Dplugins.dir=/opt/pinot/plugins -Xms1G -Xmx4G -XX:+UseG1GC -XX:MaxGCPauseMillis=200 -Xloggc:gc-pinot-controller.log" \
    -d ${PINOT_IMAGE} StartController \
    -zkAddress pinot-zookeeper:2181

docker run --rm -ti \
    --network=pinot-demo \
    --name pinot-broker \
    -p 8099:8099 \
    -e JAVA_OPTS="-Dplugins.dir=/opt/pinot/plugins -Xms4G -Xmx4G -XX:+UseG1GC -XX:MaxGCPauseMillis=200 -Xloggc:gc-pinot-broker.log" \
    -d ${PINOT_IMAGE} StartBroker \
    -zkAddress pinot-zookeeper:2181

docker run --rm -ti \
    --network=pinot-demo \
    --name pinot-server \
    -p 8098:8098 \
    -e JAVA_OPTS="-Dplugins.dir=/opt/pinot/plugins -Xms4G -Xmx16G -XX:+UseG1GC -XX:MaxGCPauseMillis=200 -Xloggc:gc-pinot-server.log" \
    -d ${PINOT_IMAGE} StartServer \
    -zkAddress pinot-zookeeper:2181
^ In this order
πŸ‘ 1
If you want to start all components in the same docker container, you'd want to run
Copy code
docker run \
    -p 9000:9000 \
    apachepinot/pinot:0.9.3 QuickStart \
    -type batch
Or whichever QuickStart you wish to run
πŸ‘ 1
Change the image to your custom <Image>:<Tag> as needed
πŸ‘ 1
r
Thanks @saurabh dubey. It’s working for me.
πŸ‘ 1