Rajan Garg
01/20/2023, 10:57 AMAll illegal access operations will be denied in a future release
2023/01/19 12:25:41.149 INFO [PinotAdministrator] [main] Usage: pinot-admin.sh <subCommand>
Here is the dockerFile link:
https://github.com/apache/pinot/blob/master/docker/images/pinot/Dockerfile
This error is because of line 66.
can somebody please help me with this?saurabh dubey
01/20/2023, 11:14 AMRajan Garg
01/20/2023, 12:46 PMdocker run <Image>:<Tag>saurabh dubey
01/20/2023, 2:04 PMdocker run \
--network=pinot-demo \
--name pinot-zookeeper \
--restart always \
-p 2181:2181 \
-d zookeeper:3.5.6
docker run --rm -ti \
--network=pinot-demo \
--name pinot-controller \
-p 9000:9000 \
-e JAVA_OPTS="-Dplugins.dir=/opt/pinot/plugins -Xms1G -Xmx4G -XX:+UseG1GC -XX:MaxGCPauseMillis=200 -Xloggc:gc-pinot-controller.log" \
-d ${PINOT_IMAGE} StartController \
-zkAddress pinot-zookeeper:2181
docker run --rm -ti \
--network=pinot-demo \
--name pinot-broker \
-p 8099:8099 \
-e JAVA_OPTS="-Dplugins.dir=/opt/pinot/plugins -Xms4G -Xmx4G -XX:+UseG1GC -XX:MaxGCPauseMillis=200 -Xloggc:gc-pinot-broker.log" \
-d ${PINOT_IMAGE} StartBroker \
-zkAddress pinot-zookeeper:2181
docker run --rm -ti \
--network=pinot-demo \
--name pinot-server \
-p 8098:8098 \
-e JAVA_OPTS="-Dplugins.dir=/opt/pinot/plugins -Xms4G -Xmx16G -XX:+UseG1GC -XX:MaxGCPauseMillis=200 -Xloggc:gc-pinot-server.log" \
-d ${PINOT_IMAGE} StartServer \
-zkAddress pinot-zookeeper:2181
^ In this ordersaurabh dubey
01/20/2023, 2:05 PMdocker run \
-p 9000:9000 \
apachepinot/pinot:0.9.3 QuickStart \
-type batch
Or whichever QuickStart you wish to runsaurabh dubey
01/20/2023, 2:06 PMRajan Garg
01/20/2023, 4:22 PM