Hi team, I deployed pinot and kafka in kubernetes ...
# general
v
Hi team, I deployed pinot and kafka in kubernetes and was trying to integrate kafka as a source for pinot. I am facing an error as below: These are the logs from pinot-controller
Transient Exception: Could not get partition count for topic test1
org.apache.pinot.spi.stream.TransientConsumerException: <http://org.apache.pinot.shaded.org|org.apache.pinot.shaded.org>.apache.kafka.common.errors.TimeoutException: Failed to get offsets by times in 5002ms
. . .
Caused by: <http://org.apache.pinot.shaded.org|org.apache.pinot.shaded.org>.apache.kafka.common.errors.TimeoutException: Failed to get offsets by times in 5002ms
If I describe the topic using kafka cli, I am able to see the partition count Kafka is deployed in another namespace and its version is 2.13-2.6.3 Please help if anyone has faced this error. TIA