https://pinot.apache.org/ logo
#getting-started
Title
# getting-started
t

Tiger Zhao

08/26/2021, 7:16 PM
By default, is the broker supposed to limit queries to 10 results?
In order to get more than 10 results, I have to add a LIMIT in my query. One strange thing I noticed is that as I arbitrarily increase this limit to something like LIMIT 100000000, the query becomes significantly slower even though it still only returns 20 rows or so. Just wondering if this is expected behavior?
n

Neha Pawar

08/26/2021, 7:57 PM
is this an ORDER BY query?
t

Tiger Zhao

08/26/2021, 8:02 PM
I see the same behavior with both ORDER BY and without it.
n

Neha Pawar

08/26/2021, 8:08 PM
but for GROUP BY or just plain selection queries also ?
t

Tiger Zhao

08/26/2021, 8:59 PM
This seems to be the case for GROUP BY only
n

Neha Pawar

08/26/2021, 9:11 PM
what version are you on?
looping in @User for more insights
j

Jackie

08/26/2021, 9:25 PM
Please check the version. I remember fixing an issue recently where we pre-allocate the buffer based on the limit
t

Tiger Zhao

08/27/2021, 1:22 PM
I am on version 0.7.1
Also is there a way to make it so that the query results are not by default limited to 10 rows?
j

Jackie

08/28/2021, 5:38 PM
Can you please try 0.8.0 and see if the problem is fixed?
Currently there is no setting to tune the default 10, but it should be easy to add. Feel free to help contribute it
👍 1
t

Tiger Zhao

08/30/2021, 1:52 PM
I tried with 0.8.0 and it seems to be better
👍 1