Hi! I’m trying to update my retentionTimeValue for...
# troubleshooting
Hi! I’m trying to update my retentionTimeValue for a table, and the endpoint doesn’t seem to be working, can someone help? The body on the left has 742 days, the call is successful, but the returned response still has 738 days…
in PUT api, you want to only include the json from
{ "tableName":…}
part. Omit the OFFLINE.
starting this commit: https://github.com/apache/pinot/pull/8514 you should see them come up as
That gives me the same behavior
If possible, can you try updating one additional config property along with retentionTimeValue.
tried changing
to true - neither updated
Would disabling the table, updating config and then enabling the table again work?
not really, there’s something incorrect about the config i think. can you try editing directly from Pinot UI to just see if that works?
also, see if you get some clue from controller logs.
I found the config in the ui but I’m unable to edit it
through the swagger api you mean? That doesn’t work because it needs my company auth
no i meant this UI:
Inspected the tab, copied the path, and body its using to postman and ran it there - still no change in
When I do a diff on the body the UI generates and the one I was using before, it shows no differences
I got it! In postman, the {{baseUrl}} was set to use the controller load balancer url instead of the instead of the specific controller url
Hi Grace, I am deleting some of the messages since it has some internal urls.. please repost after masking them
👍 1