<!here>, facing some problem to load the data to a...
# troubleshooting
<!here>, facing some problem to load the data to an existing offline table data getting overwrite iam using the following command, If i tried to load the new data I'm loosing the old data any suggestions
Copy code
sudo docker run --rm -ti \
    --network=pinot-demo_default \
    -v /home/XXXX/dna/pinot/lookup2/pinot-quick-start:/home/XXXX/dna/pinot/lookup2/pinot-quick-start \
    --name pinot-batch-table-creation \
    apachepinot/pinot:latest AddTable \
    -schemaFile /home/XXXX/dna/pinot/lookup2/pinot-quick-start/orders-schema.json \
    -tableConfigFile /home/XXXX/dna/pinot/lookup2/pinot-quick-start/orders-table-offline.json \
    -controllerHost manual-pinot-controller \
    -controllerPort 9000 -exec

sudo docker run --rm -ti \
    --network=pinot-demo_default \
    -v /home/XXXX/dna/pinot/lookup/pinot-quick-start:/home/XXXX/dna/pinot/lookup/pinot-quick-start \
    --name pinot-data-ingestion-job \
    apachepinot/pinot:latest LaunchDataIngestionJob \
    -jobSpecFile /home/XXXX/dna/pinot/lookup/pinot-quick-start/docker-job-spec.yml
I wonder if this makes it override
overwriteOutput: true
in your docker-job-spect copy.yml
sorry i have attached wrong file ... here is the actual one
@Varagini Karthik friendly reminder, please do not use
. We want to be respectful of everyone in this community slack channel.
ohk @Troy Doles
thankyou 1
I think the new data is likely creating a segment with the same name as the old data
is there a timestamp as one of your columns?
that's probably the easiest way to ensure a unique segment name
thanks @Mark Needham, yes, both the segments are creating with same name... I tried by proving the following details , It solved my problem... thanks a ton
Copy code
  type: fixed
    segment.name: 'orders1'