Hello, i wonder if there is any guidance on troubl...
# troubleshooting
m
Hello, i wonder if there is any guidance on troubleshoot ingestion issues. We have a table set up consuming from Kafka, but nothing is ingested. And there is no such info/warn/error events showing up in the logs either.
j
Can you please check the log on both controller and server? There should be logs on why the consumption didn't start
m
Hi @Jackie, yes I did but there was nothing. Also tried the debug table API and it shows the table status is healthy…
j
Hmm, can you share the table config?
Can you also confirm that events are already pushed to Kafka?
m
It turned out the default
conf/log4j2.xml
didn’t work for us. After fixing it, we could see events being logged. With respect to the specific issue, it seems the consumption stopped right after it started.
The “info” message is like
Instance s<ins_name> stopped consuming segment <seg_name> at offset <offset>, …, reason: java.lang.RuntimeException
we did check the message at that specific offset but didn’t find anything wrong about it. @Jackie Is there a way to get the details of this
RuntimeException
?
j
You should be able to find some
WARN
and
ERROR
logs explaining the exception
m
Didn’t see any around this info message. Any idea?
Never mind. I’ve found them. Thanks so much for your help @Jackie!