Hi everyone I am trying to set up monitoring and f...
# troubleshooting
a
Hi everyone I am trying to set up monitoring and for that using this
Copy code
ALL_JAVA_OPTS="-javaagent:jmx_prometheus_javaagent-0.12.0.jar=8088:pinot.yml -Xms4G -Xmx4G -XX:MaxDirectMemorySize=30g -Dlog4j2.configurationFile=conf/pinot-admin-log4j2.xml -Dplugins.dir=$BASEDIR/plugins"
sudo bin/pinot-admin.sh StartController -configFileName /home/centos/controller.conf
But could not access the metrics at 8088 port
x
where is your
jmx_prometheus_javaagent-0.12.0.jar
?
try to use the absolute path
👀 1
a
Used absloute path still not working
x
what’s the response when you do
curl localhost:8088/metrics
a
Failed to connect to 172.21.155.4 port 8088: Connection refused
x
hmm, does pinot running start?
a
Yeah pinot is running fine
Only metrics don’t come
j
Can you try setting JAVA_OPTS instead of ALL_JAVA_OPTS e.g.
Copy code
$ cd /home/centos
$ sudo yum install -y java-11-openjdk 
$ wget <https://repo1.maven.org/maven2/io/prometheus/jmx/jmx_prometheus_javaagent/0.12.0/jmx_prometheus_javaagent-0.12.0.jar>
$ wget <https://raw.githubusercontent.com/fx19880617/jmx_exporter/master/example_configs/pinot.yml>
$ wget <https://archive.apache.org/dist/pinot/apache-pinot-0.9.2/apache-pinot-0.9.2-bin.tar.gz>
$ tar -xvf apache-pinot-0.9.2-bin.tar.gz
$ cd apache-pinot-0.9.2-bin
$ bin/pinot-admin.sh StartZookeeper -zkPort 2181 &
$ export JAVA_OPTS="-javaagent:/home/centos/jmx_prometheus_javaagent-0.12.0.jar=8080:/home/centos/pinot.yml -Xms4G -Dlog4j2.configurationFile=conf/log4j2.xml -Dpinot.admin.system.exit=true"
$ bin/pinot-admin.sh StartController -zkAddress localhost:2181 -clusterName PinotCluster -controllerPort 9001 &
$ curl -s localhost:8080/metrics
👍 1
a
It is running now but only if the zookeeper is localhost:2181 which is not in my case
x
you can change
ALL_JAVA_OPTS
to
JAVA_OPTS
a
Yeah it's working fine now Thanks