Hello, do you have any news on this issue <https:/...
# troubleshooting
e
Hello, do you have any news on this issue https://github.com/apache/pinot/issues/7461 ? I have a column named
timestamp
and I’m unable to use PrestoDB since double quotes are removed
m
@Xiang Fu
Just curious @eywek, does single quote work?
e
nope since single quotes are used for values, so Presto returns an error
Copy code
'>=' cannot be applied to varchar(9), timestamp with time zone
x
How you tried double quotes?
e
Copy code
SELECT count(*) FROM pinot.default.datasource_607ec74cd839000300105f34 WHERE "timestamp" >= from_iso8601_timestamp('2021-12-24T00:00:00.000Z') AND "timestamp" <= from_iso8601_timestamp('2021-12-30T23:59:59.999Z') LIMIT 5000
which is translated to
Copy code
SELECT count(*) FROM datasource_607ec74cd839000300105f34 WHERE ((timestamp >= 1640304000000) AND (timestamp <= 1640908799999))
x
Timestamp is presto reserved keyword, we suggest not to have it as column name
e
same in Pinot, but I have it and I can’t change my column name
do you know if there is any workaround?
x
You can try to create a derived column with a different column name then reload segment
In the transform function, you just put timestamp column name there
Or maybe some simple expression like timestamp + 0
e
And without updating the schema?
e
(btw this is a bug on presto side or on yours?)
x
You have to update schema
It's on presto side to handle escape for Pinot
👍 1
Though the presto connector code is also maintained by me 😂
e
oh, and do you plan to fix this? or maybe you could tell me where I can fix this and I’ll try to open a PR
x
I'm traveling now, will update you soon.