Elon
01/19/2022, 8:07 PMWARN [BaseInstanceSelector] [HelixTaskExecutor-message_handle_thread] Failed to find servers hosting segment: MYTABLE-1641542240329_2022-01-06_2022-01-06_6 for table: MYTABLE
When we issue the rebuild routing table api to the broker it just rebuilds an identical routing table with the same missing servers/segments. Is there any way to resolve that? We are also looking... could it be related to ZkCacheBaseDataAccessor not refreshing?Elon
01/19/2022, 8:13 PMMayank
Elon
01/19/2022, 11:21 PMElon
01/19/2022, 11:22 PMElon
01/19/2022, 11:22 PMElon
01/19/2022, 11:23 PMJohan Adami
01/19/2022, 11:50 PMJohan Adami
01/19/2022, 11:51 PMElon
01/19/2022, 11:51 PMElon
01/19/2022, 11:52 PMElon
01/19/2022, 11:52 PMJohan Adami
01/20/2022, 12:01 AMElon
01/20/2022, 12:01 AMJohan Adami
01/20/2022, 12:09 AM-XX:+ExitOnOutOfMemoryError set when you run the broker? And how certain are you that restarting it is actually restarting? we’ve seen some cases where we send SIGTERM and the broker just hangs especially when it’s in the middle of building the routing table.Elon
01/20/2022, 12:10 AMElon
01/20/2022, 12:10 AMElon
01/20/2022, 12:25 AMElon
01/20/2022, 12:26 AMMayank
Jackie
01/20/2022, 12:31 AMONLINE in EV, check the online servers and see if they are in liveInstances and if they if queries disabled in Helix InstanceConfigElon
01/20/2022, 12:32 AMElon
01/20/2022, 12:32 AMElon
01/20/2022, 12:32 AMJackie
01/20/2022, 12:32 AMJackie
01/20/2022, 12:33 AMElon
01/20/2022, 12:33 AMElon
01/20/2022, 12:33 AMElon
01/20/2022, 12:33 AMElon
01/20/2022, 12:36 AMJackie
01/20/2022, 12:37 AM0.8.0Elon
01/20/2022, 12:37 AMJackie
01/20/2022, 12:37 AMElon
01/20/2022, 12:37 AMElon
01/20/2022, 12:37 AMZkCacheBaseDataAccessor code?Jackie
01/20/2022, 12:37 AMFailed to find servers hosting segment: MYTABLE-1641542240329_2022-01-06_2022-01-06_6 for table: MYTABLEJackie
01/20/2022, 12:38 AMLOGGER.warn(
"Failed to find servers hosting segment: {} for table: {} (all ONLINE/CONSUMING instances: {} and OFFLINE "
+ "instances: {} are disabled, counting segment as unavailable)", segment, _tableNameWithType,
onlineInstancesForSegment, offlineInstancesForSegment);Elon
01/20/2022, 12:38 AMElon
01/20/2022, 12:39 AMJackie
01/20/2022, 12:39 AMElon
01/20/2022, 1:01 AMElon
01/20/2022, 1:49 AMWARN [BaseInstanceSelector] [HelixTaskExecutor-message_handle_thread] Failed to find servers hosting segment: MYTABLE-1642556066145_2021-12-03_2021-12-03_4 for table: MYTABLE (all ONLINE/CONSUMING instances: [Server_pinot-us-central1-server-zonal-41.pinot-us-central1-server-headless.pinot.svc.cluster.local_8098, Server_pinot-us-central1-server-zonal-42.pinot-us-central1-server-headless.pinot.svc.cluster.local_8098, Server_pinot-us-central1-server-zonal-43.pinot-us-central1-server-headless.pinot.svc.cluster.local_8098] and OFFLINE instancesElon
01/20/2022, 1:49 AMElon
01/20/2022, 2:20 AMJackie
01/20/2022, 5:55 AMElon
01/20/2022, 7:52 AMChinmay Soman
01/20/2022, 7:13 PM