Hello team, I wanted to drop a server instance fro...
# troubleshooting
y
Hello team, I wanted to drop a server instance from a cluster to shrink cluster size. So I executed command below after helm chart update but met an error.
Copy code
curl -XDELETE localhost:9000/instances/Server_pinot-server-2.pinot-server-headless.dev-pinot.svc.cluster.local_8098

{"_code":409,"_error":"Failed to drop instance Server_pinot-server-2.pinot-server-headless.dev-pinot.svc.cluster.local_8098 - Instance Server_pinot-server-2.pinot-server-headless.dev-pinot.svc.cluster.local_8098 exists in ideal state for user2_REALTIME"}
• What will happen if i update zk's idealstate of all tables related to server-2 to server-1? (table status became healthy again) • Will also there be automatic copy based on other segment to maintain replica desire?
y
@Kishore G Thanks a lot! I tried that one through GUI after server deletion but met this one.
Copy code
Caused by: java.net.UnknownHostException: pinot-server-2.pinot-server-headless.dev-pinot.svc.cluster.local
Additionally, before that, I didn't read the log then but there were always message that segments are balanced.
m
I think the sequence is to first untag the server, then rebalance, and then remove the server.
y
@Mayank Thanks for reply. I got aware of untag now. Does the rebalance do same thing internally with what i did?
It just works now so that's why I am asking
m
Rebalance does not untag.