This message was deleted.
# troubleshooting
s
This message was deleted.
g
the error is due to losing session w/ zookeeper
wild guess: most common reason for this is servers going temporarily offline due to very long GC pauses, which would in turn be due to memory pressure
is it possible this is happening in your case?
k
yes we are seeing few OOM errors and the hprof file size is around 80 GB . is there a easy way to identify which query is causing this issue ?
g
not really, since OOME happens at the level of the entire JVM. and an 80 GB heap file is going to be tough to open on a workstation! i'd consider lowering the heap size a bit — maybe to 16 GB — triggering the OOME again, then opening the resulting hprof on a workstation that has > 16 GB of RAM this will let us see the objects that are taking up the space, which generally makes it pretty clear what the cause is
that's going to be set up by default in 24.0 (next release)
k
sure will check