This message was deleted.
# troubleshooting
s
This message was deleted.
j
Also, running
kubectl logs druid-test-historical-9 --previous
does not give me any extra info
a
What does
kubectl describe pod ...
show for the termination reason? It's possible Kubernetes OOMKiller is killing it.
j
Dont think it’s getting OOMKilled, running your command in events:
Copy code
Events:
  Type     Reason     Age                     From     Message
  ----     ------     ----                    ----     -------
  Warning  BackOff    14m (x326 over 118m)    kubelet  Back-off restarting failed container
  Warning  Unhealthy  9m18s (x102 over 128m)  kubelet  Liveness probe failed: Get "<http://10.3.134.21:8083/status/health>": dial tcp 10.3.134.21:8083: connect: connection refused
  Normal   Pulled     4m9s (x35 over 129m)    kubelet  Container image "apache/druid:24.0.0" already present on machine
it just never ends loading all segments and it exists but no error or relevant info that tell me what the problem was
I have 12 historical in total, 10 of them are running properly, 1 of them has not been created yet and the other is in this weird state where it exists
well it looks like it ended up running after so many restarts attempts
a
you lll need to increase your probe time
k8s will restart the pod if does not go 1/1 by a certain threshold.
j
Can you elaborate more on that?