Slackbot
11/16/2022, 5:01 PMSergio Ferragut
11/16/2022, 6:03 PMsridhara
11/16/2022, 6:19 PMSergio Ferragut
11/16/2022, 6:23 PMsridhara
11/16/2022, 6:27 PMUnable to load database on disk
java.io.IOException: Unreasonable length = 8522996sridhara
11/16/2022, 6:28 PMsridhara
11/16/2022, 6:29 PMsridhara
11/16/2022, 6:30 PMKaran Kumar
11/16/2022, 6:41 PMSergio Ferragut
11/16/2022, 6:54 PMdruid.serverview.type=http
druid.coordinator.loadqueuepeon.type=http
druid.indexer.runner.type=httpRemotesridhara
11/16/2022, 8:24 PMArvind Singh
11/16/2022, 8:29 PMArvind Singh
11/16/2022, 8:31 PM2022-11-16 20:18:54,446 [myid:3] - INFO [main:ZKAuditProvider@42] - ZooKeeper audit is disabled.
2022-11-16 20:18:54,606 [myid:3] - ERROR [main:QuorumPeer@1148] - Unable to load database on disk
java.io.IOException: Unreasonable length = 8523180Didip Kerabat
11/16/2022, 8:34 PMArvind Singh
11/16/2022, 8:35 PMDidip Kerabat
11/16/2022, 8:35 PMDidip Kerabat
11/16/2022, 8:36 PMDidip Kerabat
11/16/2022, 8:39 PMjvmFlags: "-Djute.maxbuffer=16777216"
Step 2: Enlarge the limit on Druid side by setting the same thing on every JVM options:
-Djute.maxbuffer=16777216
Obviously you have to restart everything for the settings to take place.
Step 3: Problem solved.Arvind Singh
11/16/2022, 8:40 PMsridhara
12/21/2022, 7:28 AMDidip Kerabat
12/21/2022, 3:52 PM