This message was deleted.
# troubleshooting
s
This message was deleted.
s
Hi @sridhara. Do you mean you are attempting to use zookeeper as the metadata database for Druid? I don't think that is a supported configuration. Zookeeper is used in Druid for interprocess communication and for leader election, but I've never seen it used as a Metadata database component. For that you can use postgres, mysql. Or am I misunderstanding?
s
@Sergio Ferragut yeah it is for interprocess communication onIy... what metadata i mean is here the segments information we store right that is why i just mentioned as metadata
s
I see. Okay, can you provide more context? How are you deploying it? Is this a fresh install? Does this occur on startup or when does it occur?
s
@Sergio Ferragut It was working for months now and all of sudden we started seeing this issue today... where in our zookeeper went into bad state and we lost quorum... This is the error that zookeeper is failing with
Copy code
Unable to load database on disk
java.io.IOException: Unreasonable length = 8522996
we tried to restore from the backup it was functioning for 2 hours and then it started the issue again
we are trying to understand is above issue was due to above jira
k
I am not sure what this bug is but I would try to use zookeeper as less as possible. For that use http based load queues and http task runner. I think that would elevate the pressure on zookeeper.
s
Just to add to @Karan Kumar’s point. Those settings are:
druid.serverview.type=http
druid.coordinator.loadqueuepeon.type=http
druid.indexer.runner.type=httpRemote
s
@Arvind Singh 👆
a
We are getting the above issue and zookeeper is not coming up. Here Zookeeper is running as a Kubernetes service.
Is there anyway to bring up zookeeper by resolving the below issue:
Copy code
2022-11-16 20:18:54,446 [myid:3] - INFO  [main:ZKAuditProvider@42] - ZooKeeper audit is disabled.
2022-11-16 20:18:54,606 [myid:3] - ERROR [main:QuorumPeer@1148] - Unable to load database on disk
java.io.IOException: Unreasonable length = 8523180
d
By any chance, is your ingestion spec huge?
a
Yes
d
We had this same issue before. The huge payload is bumping against ZK’s default limit.
Do you deploy ZK with Bitnami Zookeeper Helm chart?
Step 1: Enlarge the limit on ZK itself:
Copy code
jvmFlags: "-Djute.maxbuffer=16777216"
Step 2: Enlarge the limit on Druid side by setting the same thing on every JVM options:
Copy code
-Djute.maxbuffer=16777216
Obviously you have to restart everything for the settings to take place. Step 3: Problem solved.
🔥 1
a
Thanks a lot. Let me try it
s
@Didip Kerabat Should we keep the max jute buffer size for zookeeper and druid same ? If it is same will that not effect zookeeper anything?
d
yes but had to be the same