Hello Everyone
Can someone help me on below...
Note: I am using Single-Server Druid Node [with 8 cpu / 64 gb ram] and executing the druid service using AUTO config nohup ./bin/start-druid &
I tried to change the middlemanager runtime.properties by adding -XX:maxDirectMemorySize as follows
druid.indexer.runner.javaOptsArray=["-server","-Xms1g","-Xmx1g","-XX:MaxDirectMemorySize=1g","-Duser.timezone=UTC","-Dfile.encoding=UTF-8","-XX:+ExitOnOutOfMemoryError","-Djava.util.logging.manager=org.apache.logging.log4j.jul.LogManager"]
But it didn't start the druid service once I invoked the nohup ./bin/start-druid &
Unless I remove above changes... druid service not starting.
Are we can't change the runtime.properties in middlemanager, historical, etc services... while we use AUTO druid config to execute !??
Thank You