This message was deleted.
# general
s
This message was deleted.
🙏 1
👍 3
druid 3
d
Just tried upgrading Helm package from 0.3.4 to 0.3.5. The operator failing to start with this message:
Copy code
ERROR    setup    unable to start manager    {"error": "must specify more than one namespace to use multi-namespace cache"}                                                                          
 main.main                                                                                                                                                                                                                    
     /workspace/main.go:93                                                                                                                                                                                                    
 runtime.main                                                                                                                                                                                                                 
     /usr/local/go/src/runtime/proc.go:250
Any default settings that have changed?
a
@Dmitry Livchak what is the value you have for
WATCH_NAMESPACE
in your values ?
d
it's a single namespace like the message suggests
it's been running our PoC cluster for a month or so before today's upgrade
a
can you share your deployment yaml.
Copy code
kubectl get deploy <druid-operator-deployment> -o yaml -n <druid-operator-namespace>
I have cache disabled on my cluster, let me enable and double check. If you can share the yaml it would be helpful. Thank you
i am also assuming you are doing a cluster scope installation as described here
d
no, it's a namespaced one
👍 1
Copy code
resource "helm_release" "druid-operator" {

  namespace        = "something was here"
  name             = "something was here"
  version          = "0.3.5"
  create_namespace = true

  repository = "<https://charts.datainfra.io>"
  chart      = "druid-operator"
  wait       = true

  set {
    name  = "env.WATCH_NAMESPACE"
    value = local.druid_cluster_namespace
  }

  set {
    name  = "scalePvcSts"
    value = "true"
  }
}
This is the Terraform definition of the Helm deployment
as you can see, it's pretty much vanilla
The only thing that has changed today is
0.3.4 -> 0.3.5
for the version
If I revert back to
0.3.4
all is back to normal
a
i found the bug, will send a fix and release soon. Thanks @Dmitry Livchak I run my clusters cluster scoped so dint hit it. ðŸĪŠ
d
Thank you! This is a very impressive turnaround
d
Just deployed - working well so far, thank you!