Slackbot
03/30/2023, 12:33 AMBen Krug
03/30/2023, 12:53 AMHao Wang
03/30/2023, 12:56 AMBroken pipe error messages. Anyway to stop the Druid from doing this?Hao Wang
03/30/2023, 1:18 AMHao Wang
03/30/2023, 1:21 AMtoo large[7,536,245 > 524,288] so I need at least 8mb for the znode size … but how to reduce the data size?Ben Krug
03/30/2023, 1:25 AMHao Wang
03/30/2023, 1:27 AMmaxNumFiles But in my case, what would be a good number?Vijay Narayanan
03/30/2023, 1:28 AMHao Wang
03/30/2023, 1:32 AMVijay Narayanan
03/30/2023, 5:27 AMVijay Narayanan
03/30/2023, 5:28 AMKyle Hoondert
03/30/2023, 7:07 AMhttpRemote druid.indexer.runner.type has been around for a while https://druid.apache.org/docs/latest/configuration/index.html#overlord-operationsVijay Narayanan
03/30/2023, 8:27 AMKyle Hoondert
03/30/2023, 10:27 AMHao Wang
03/30/2023, 4:42 PMorg.apache.druid.java.util.common.IAE: Length of raw bytes for znode[/druid/indexer/tasks/10.34.35.19:8091/partial_index_generic_merge_mus_freeform_poc_v8_jcgbmmbl_2023-03-30T10:
37:29.444Z] too large[12,019,976 > 1,000,000]
So should I figure out how to reduce the length of raw bytes? Or should I see how to make Druid able to write large raw bytes? Thanks!Vijay Narayanan
03/30/2023, 4:49 PMHao Wang
03/30/2023, 5:40 PMException while trying to assign task: {class=<http://org.apache.druid.in|org.apache.druid.in>
dexing.overlord.RemoteTaskRunner, exceptionType=class org.apache.druid.java.util.common.IAE, exceptionMessage=Length of raw bytes for znode[/druid/indexer/tasks/10.34.35.19:8091/
partial_index_generic_merge_mus_freeform_poc_v8_jcgbmmbl_2023-03-30T10:37:29.444Z] too large[12,019,976 > 1,000,000], taskId=partial_index_generic_merge_mus_freeform_poc_v8_jcgbm
mbl_2023-03-30T10:37:29.444Z}
I can try to explicitly configure it this way tho. What do you think?Hao Wang
03/30/2023, 5:45 PMDidip Kerabat
03/30/2023, 6:33 PM-Djute.maxbuffer=16777216 on both zk client and the zk server.Hao Wang
03/30/2023, 8:16 PMBen Krug
03/30/2023, 8:20 PMDjute.maxbuffer=16777216 idea is a good call, I'd try it.Ben Krug
03/30/2023, 8:20 PMHao Wang
03/30/2023, 8:22 PMNAME READY STATUS RESTARTS AGE
druid-coordinator-5cd78995cb-rckfc 1/1 Running 3 (23m ago) 134m
And the error message is still from Liveness/Readiness Prob for connection reset by peer:
Warning Unhealthy 26m kubelet Readiness probe failed: Get "<http://10.34.3.93:8081/status/health>": read tcp 10.34.7.138:35060->10.34.3.93:8081: read: connection reset by peer
Warning Unhealthy 26m kubelet Liveness probe failed: Get "<http://10.34.3.93:8081/status/health>": read tcp 10.34.7.138:35062->10.34.3.93:8081: read: connection reset by peerBen Krug
03/30/2023, 8:30 PMHao Wang
03/30/2023, 8:33 PMjute.maxbuffer for Druid cluster?Ben Krug
03/30/2023, 8:36 PMBen Krug
03/30/2023, 8:36 PMHao Wang
03/30/2023, 8:38 PMBen Krug
03/30/2023, 9:37 PMDidip Kerabat
03/30/2023, 10:28 PMVijay Narayanan
03/30/2023, 10:47 PMDidip Kerabat
03/30/2023, 11:00 PMHao Wang
03/30/2023, 11:01 PMHao Wang
03/30/2023, 11:07 PM[LookupCoordinatorManager--3] org.apache.druid.server.lookup.cache.LookupCoordinatorManager - Failed to finish lookup management on node [http:10.34.71.105:8083]
: {class=org.apache.druid.server.lookup.cache.LookupCoordinatorManager, exceptionType=class java.util.concurrent.ExecutionException, exceptionMessage=org.jboss.netty.handler.timeout.ReadTimeo
utException}
But I don’t think it is the root cause. The coordinator itself just become super slow when the data ingestion is almost completed, but disk is not full and cpu is not highly utilized and I believe 2G memory should be enough. Any idea about what is going on?Didip Kerabat
03/30/2023, 11:08 PMDidip Kerabat
03/30/2023, 11:09 PMHao Wang
03/30/2023, 11:09 PMHao Wang
03/30/2023, 11:10 PMDidip Kerabat
03/30/2023, 11:10 PMHao Wang
03/30/2023, 11:13 PMHao Wang
03/30/2023, 11:13 PM