This message was deleted.
# troubleshooting
s
This message was deleted.
a
you should check the router logs for any errors.
m
Unfortunately no ERRORs, people able to access but don’t see anything in the dashboard.
Resolved the issue (not related to Druid itself 🙂 ) Enabled debug logs for LdapRoleProvider and found following: https://github.com/apache/druid/blob/8296123d895db7d06bc4517db5e767afb7862b83/exte[…]apache/druid/security/basic/authorization/LDAPRoleProvider.java
Copy code
2023-03-22T12:27:34,343 DEBUG [qtp1608217492-138] org.apache.druid.security.basic.authorization.LDAPRoleProvider - No memberOf attributes
2023-03-22T12:27:34,343 DEBUG [qtp1608217492-138] org.apache.druid.security.basic.authorization.LDAPRoleProvider - User USER is not mapped to any groups
We found after some
ldapsearch
games, that LDAP bind user that was created by our IT from some reason didn’t return 😑
Copy code
memberOf attributes
Worked with other user.