:octavia-rocket: octavia-cli updates :octavia-rock...
# help-api-cli-orchestration
octavia rocket octavia-cli updates octavia rocket Hello dear Octavia followers! I'm very excited to share that we will soon have the tool ready for an official alpha release🎉! I'm looking for a couple of alpha testers to ensure no critical bug is hidden in the codebase before the release. Are some of you interested in trying to install and use the tool and share feedback with me? Feel free to reach out in the thread if you're available this week. The CLI is still alpha, and some features are not yet implemented; feel free to track the planned additions in our Github issues.
hey Augustin, I had two unsuccessful attempts on different occasions at building and using the tool but I'm ready to revisit again https://airbytehq.slack.com/archives/C02RRUG9CP5/p1645797430088869
Hi @Dejan Antonic, you can now use the tool without building it locally. Feel free to check the README to find instructions on how to install and let me know if you can use the tool as expected 😄
🙏 1
@User this is awesome, it took me literally three steps to be able to run Octavia commands: 1. run the curl command from the README 2. log into k8s cluster 3. port-forward webapp service Will be back with more feedback later...
🎉 1
trying to obtain a list of source connectors gave me nothing e.g.
octavia list connectors sources
while getting a list of destinations with
octavia list connectors destinations
resulted in 34 destinations being displayed, is the list of source connectors supposed to return empty?
Hi Dejan! Glad to hear you were able to install the tool! Could you please try again to list connectors for sources? I realized that sometimes the API behaves a bit strangely and does not return anything. On my side, the
octavia list connectors sources
usually work flawlessly.
ok tried once again and got nothing and then tried yet again and it took a few seconds longer but api returned 128 sources!
Cool 😄 I'm afraid this problem could be on the API server-side, if you encounter this again do you mind running
curl -X POST <http://localhost:8000/api/v1/source_definitions/list>
and check if you get a response?
👍 1
I'm not able to reproduce this bug easily. My intuition is: the API returns a valid response, but empty, otherwise an exception would have been raised.
having trouble reproducing it again, oh well, let's move on for now 😄
workspaces return fine
so do workspace sources and workspace destinations
👍🏻 1
trying to run generate or apply commands before initializing the project doesn't crash anything and user is notified they must run octavia init first which is expected behavior
octavia init
results in the following error even though the instance is available and running
🤔 1
What does
curl -X POST <http://localhost:8000/api/v1/health>
return? 😄
restarting the connection seems to have solved the problem
message has been deleted
Looks like the port forward makes the HTTP requests a bit flickering
trying to generate source e.g.
octavia generate source 9fa5862c-da7c-11eb-8d19-0242ac130003 cockroach-db
results in a yaml file being created successfully, subsequent execution of octavia apply however results in the following error which is expected because we didn't edit configuration yet
👍🏻 Yep, the configuration validation happens server-side and we did not yet make the error more readable, but this error should still have the exhaustive validation error.
generating an s3 destination works as expected
octavia generate destination 4816b78f-1489-44c1-9060-4b19d5fa9362 s3
octavia apply
behaves the same before configuration is edited
trying to generate a connection before you successfully run octavia apply (you will need to edit configuration for both of your source and destination yamls before running octavia apply successfully) results in an error informing you of the same which is expected behavior