Hi, I am facing an issue while trying to access th...
# replication-troubleshooting
h
Hi, I am facing an issue while trying to access the google cloud SQL data as airbyte source connector. Anyone can help on this?
m
Hello @Hemanta what is the problem you’re having? Can you share the complete log file and connector version you’re using?
h
Hello @Marcos Marx (Airbyte), I am unable to connect to PostgreSQL. Every time I am getting the connection refused error on the local host. Don't know, what's causing the issue. I tried a lot but didn't find any solution yet
m
Did you allow your local/Airbyte instance to access in GCP network?
h
I am currently running it from local not using GCP
m
But did you create a network rule to allow your local to access the SQL Cloud database?
h
Well, do I need to do that? I am actually trying to connect to the local postgresql
m
Your question is:
Hi, I am facing an issue while trying to access the google cloud SQL data as airbyte source connector. Anyone can help on this?
Can you explain what is it your issue? Try to describe all steps please.
h
Well, the issue is my airbyte is running in the GCP cloud through Kubernetes. To access it locally, one needs to set up the required packages, and then it can access locally and it will run on localhost with post 8000. My platform DB is running in google cloud SQL. To access it locally need to set up a cloud SQL proxy then it will run on localhost and the port number is 5432. So, I am trying to set up the PostgreSQL source connector by running airbyte. After providing all information, while clicking setup source, after some time getting timeout error.
I hope you understand. If you need more clarification, let me know
m
Are you trying to use
localhost
? Because it won’t work like this. You must allow the Kuberentes IP to access our PostgresSQL Cloud instance creating the correct network rules. Please check with your security/infra team to help you.
h
Yes, I am using localhost. So, do you have any documentation regarding this?
m
No, this is related to infra/network configuration not Airbyte
h
BTW, our infra team already set up the infrastructure for airbyte and also for airbyte-DB. Do they need to do any other modifications?
m
They must create a network rule for airbyte-db to allow be accessed by the airbyte cluster.
h
Well, the airbyte is running on GCP Kubernetes. So, I think they need to create the network rule from there. Right?
m
Yes @Hemanta
h
Thanks a lot. This means a lot