hello, exists a way to up this limit io.grpc.Statu...
# replication-troubleshooting
f
hello, exists a way to up this limit io.grpc.StatusRuntimeException: RESOURCE_EXHAUSTED: grpc: received message larger than max (11993702 vs. 4194304)
s
Hey there, what airbyte version are you running and when exactly did this error occur? Did it happen when you ran a sync or when you first configured the connector? The issue can be traced back to this report in temporal's forum: https://community.temporal.io/t/grpc-message-size-limit/1128 Depending on when it happened, this might be useful information in our thread here: https://discuss.airbyte.io/t/how-to-sync-thousands-of-table-using-airbyte/1858
In some cases you can have a problem to sync a large database with +10k tables. There is an Github request to solve the issue here: Discover schema fails when databases have too many tables. · Issue #3943 · airbytehq/airbyte · GitHub 14
For now the option is to create a new user and limit the access to only the tables you need to sync. If you need to sync all tables, probably you’ll need to create multiple users to break among different connectors.