Hi, quick question - is there a minimum version o...
# help-api-cli-orchestration
Hi, quick question - is there a minimum version of airbyte that octavia-cli can connect to? I am able to test and connect locally on my dev airbyte instance (latest). However, when I create an ssh tunnel to my prod instance and expose on localhost:8000 I get an error: Error: Could not reach your Airbyte instance, make sure the instance is up and running and network reachable: HTTPConnectionPool(host='localhost', port=8000): Max retries exceeded with url: /api/v1/health (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f30585704f0>: Failed to establish a new connection: [Errno 111] Connection refused')) The prod server airbyte version is a bit old 0.30.16-alpha
Hi @Hrvoje Piasevoli, the octavia-cli version should be the same as your Airbyte instance as they are both released together and octavia-cli depends on Airbyte API which might evolve version by version. This is something I need to make clear in the doc, thanks for asking.
👍 1
But your error is probably not related to API discrepancies in earlier Airbyte version.
Could you try running
octavia --airbyte-url <> list connectors sources
Hi @Augustin Lafanechere (Airbyte) thx for your help. Your suggestion doesn't work, but this works: octavia --airbyte-url http://host.docker.internal:8000 I'm running on windows+wsl+ubuntu20.40: Now I get I different (expected) error msg from api client
👍 1
Good to know thanks!
Hey @Augustin Lafanechere (Airbyte) I’m getting the same error here and I’ve tried a few different urls http://host.docker.internal:8000 http://localhost:8000 http://airbyte-webapp:8000 http://webapp:8000 The weird thing is that it works fine when running it locally on my laptop (same version and everything), but when I run the same docker compose in a GCP VM it returns this error. Have you come across with the same issue? Thanks!
Found the solution! I did http://webapp:80 and it worked! Not sure why port 80 works and not 8080 though… Hope this helps anyone with the same issue
Old thread but thought I’d add that I’ve got port forwarding going (since my local airbyte is on 8000 and my AWS VPC airbyte is on port 8888) and got it to work with this:
Copy code
octavia --airbyte-url <http://host.docker.internal:8888> list workspace destinations