Blake Miller
08/06/2026, 5:27 PM2026-08-06 10:25:58 INFO 2026-08-06 10:25:58 info
2026-08-06 10:25:58 INFO 2026-08-06 10:25:58 info Transitioning workload to running state
2026-08-06 10:25:58 INFO 2026-08-06 10:25:58 info ----- START CHECK -----
2026-08-06 10:25:58 INFO 2026-08-06 10:25:58 info
2026-08-06 10:25:58 INFO 2026-08-06 10:25:58 info Workload successfully transitioned to running state
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Connector exited, processing output
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Output file jobOutput.json found
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Connector exited with exit code 0
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Reading messages from protocol version 0.2.0
2026-08-06 10:26:16 ERROR 2026-08-06 10:26:16 error 'GET' request to '<https://googleads.googleapis.com/v20/customers:listAccessibleCustomers>' failed with status code '400' and error message: 'Request contains an invalid argument.'. Request (body): 'None'. Response (body): '{'error': {'code': 400, 'message': 'Request contains an invalid argument.', 'status': 'INVALID_ARGUMENT', 'details': [{'@type': '<http://type.googleapis.com/google.ads.googleads.v20.errors.GoogleAdsFailure|type.googleapis.com/google.ads.googleads.v20.errors.GoogleAdsFailure>', 'errors': [{'errorCode': {'requestError': 'UNSUPPORTED_VERSION'}, 'message': 'Version v20 is deprecated. Requests to this version will be blocked.'}], 'requestId': 'FN15zsmOTAD-Q1YT3s420g'}]}}'. Response (headers): '{'Request-Id': 'FN15zsmOTAD-Q1YT3s420g', 'Vary': 'Origin, X-Origin, Referer', 'Content-Type': 'application/json; charset=UTF-8', 'Content-Encoding': 'gzip', 'Date': 'Thu, 06 Aug 2026 17:26:15 GMT', 'Server': 'ESF', 'X-XSS-Protection': '0', 'X-Frame-Options': 'SAMEORIGIN', 'X-Content-Type-Options': 'nosniff', 'Alt-Svc': 'h3=":443"; ma=2592000,h3-29=":443"; ma=2592000', 'Transfer-Encoding': 'chunked'}'.
2026-08-06 10:26:16 WARN 2026-08-06 10:26:16 warn Stream customer is not available: HTTP Status Code: 400. Error: Bad request. Please check your request parameters.
2026-08-06 10:26:16 ERROR 2026-08-06 10:26:16 error Check failed
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Checking for optional control message...
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Writing output of 253487c0-2246-43ba-a21f-5116b20a2c50_ac1bae9e-007c-4f6a-8c12-cf34715abf92_0_check to the doc store
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Marking workload 253487c0-2246-43ba-a21f-5116b20a2c50_ac1bae9e-007c-4f6a-8c12-cf34715abf92_0_check as successful
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info Deliberately exiting process with code 0.
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 info ----- END CHECK -----
2026-08-06 10:26:16 INFO 2026-08-06 10:26:16 infokapa.ai
08/06/2026, 5:27 PM'errors': [{'errorCode': {'requestError': 'UNSUPPORTED_VERSION'}, 'message': 'Version v20 is deprecated. Requests to this version will be blocked.'}]
Your connector is making requests to Google Ads API v20, which Google has now deprecated and blocked. This is why it broke randomly — Google deprecated that API version on their end, not something you changed. [deprecated version issue]
What's happening The connector's listAccessibleCustomers endpoint is being called against https://googleads.googleapis.com/v20/customers:listAccessibleCustomers, but v20 is no longer supported by Google. The current Airbyte source-google-ads connector in the main codebase uses v23 of the Google Ads API. [manifest.yaml]
What to do 1. Update your connector to the latest version. You mentioned it's on the latest version, but the fact that it's still calling v20 suggests the connector image being used may not actually be the most current release. The latest code in the Airbyte repository targets v23. Double-check the exact connector version number you're running.
2. If you're on Airbyte Cloud, the connector should be updated automatically — try refreshing or reaching out to Airbyte support, as this may be a rollout timing issue.
3. If you're self-hosting (OSS/abctl), manually upgrade the connector to the latest available version through the Airbyte UI or by pulling the latest connector image.
4. Re-authentication will not fix this — the issue is the API version being called, not your credentials.
The knowledge sources do not contain the specific version number that introduced v23 support, so I'd recommend checking the Airbyte connector changelog directly to confirm which version you should be on. 👍 0 button 👎 0 button ℹ️ Tip: Mention @kapa.ai in the thread for follow-ups or DM the app for 1-to-1 help.Blake Miller
08/06/2026, 5:30 PMBlake Miller
08/06/2026, 5:36 PMkapa.ai
08/06/2026, 5:37 PMdocs.airbyte.com/assets/images/google-ads-migrations-1.png▾
Blake Miller
08/06/2026, 5:39 PMkapa.ai
08/06/2026, 5:39 PMBlake Miller
08/06/2026, 5:40 PMkapa.ai
08/06/2026, 5:40 PMsource-google-ads version stuck 4.1.4
◦ source-google-ads upgrade not working
◦ source-google-ads v20 deprecated
This may surface existing reports from other users experiencing the same upgrade problem, or you can file a new issue with the details from your logs and screenshots. 👍 0 button 👎 0 button ℹ️ Tip: Mention @kapa.ai in the thread for follow-ups or DM the app for 1-to-1 help.Blake Miller
08/06/2026, 5:41 PMBlake Miller
08/06/2026, 5:42 PMkapa.ai
08/06/2026, 5:42 PMgetSpecForImage() being called with a null workspaceId when updating connector versions. The fix was included in v1.7.0.
2. Issue #73267 — After running "Upgrade all", the UI suggested downgrades for 225 sources and 4 destinations (current 0.0.18 → "update available" 0.0.17). This appears to be a bug in the version comparison logic and is still open/under investigation.
3. Issue #61525 — Multiple connectors requiring Airbyte v1.7.0 were unavailable on v1.6.3, affecting new installs entirely. [connector version issue]
What I'd suggest • Check what version of Airbyte you're running — if you're below v1.7.0, upgrading the platform itself may resolve the connector upgrade failures.
• If you're already on v1.7.0+, issue #73267 (the downgrade/version comparison bug) seems closest to your situation and is worth following or commenting on. 👍 0 button 👎 0 button ℹ️ Tip: Mention @kapa.ai in the thread for follow-ups or DM the app for 1-to-1 help.Blake Miller
08/06/2026, 5:43 PMkapa.ai
08/06/2026, 5:43 PMconnector upgrade stuck 2.0.1
◦ upgrade all not working
◦ connector version not updating
1. File a new GitHub issue if you don't find an existing one, including:
◦ Airbyte version: 2.0.1
◦ Connector stuck on: Google Ads 4.1.4
◦ Steps already tried: "Upgrade all" and manual image update
◦ Your error logs showing the v20 API deprecation
1. Contact Airbyte Support via the in-app chat or airbyte.com/contact for direct assistance. 👍 0 button 👎 0 button ℹ️ Tip: Mention @kapa.ai in the thread for follow-ups or DM the app for 1-to-1 help.