<@U04S8PLJWMT> I recall sometime ago that in order...
# replication-ask-ai
j
@kapa.ai I recall sometime ago that in order to upgrade the airbyte platform past version 0.63, that the connector's must be on a certain version of the CDK or higher. Is that true? Has there ever been this situation?
k
There has been a related situation, but the direction was the opposite of what you’re asking: - Some **connectors started requiring a minimum platform version** (not the other way around). For example, the August 2024 release notes state that Postgres destination v2.3.0 “requires Airbyte platform v0.63.7” to use that connector version.[[August 2024 notes](https://docs.airbyte.com/release_notes/aug_2024)] - When a connector that uses newer CDK / protocol features is run on an older platform, you can get errors like: “You must upgrade your platform version to use this connector version. Either downgrade your connector or upgrade platform to 0.63.7.”[[BigQuery issue](https://github.com/airbytehq/airbyte/issues/59702); [Postgres issue](https://github.com/airbytehq/airbyte/issues/54691)] This is exactly what some users saw with BigQuery and Postgres destinations. - For OSS users, the UI now warns when “upgrading a connector requires a specific corresponding platform version,” again indicating connector → platform requirements.[[July 2024 notes](https://docs.airbyte.com/release_notes/july_2024#connector-improvements)] The protocol versioning docs describe safeguards the other way around: when upgrading the platform, it checks that existing connectors’ protocol versions are still supported and will abort the upgrade if not, prompting you to upgrade those connectors first.[[Protocol versioning](https://docs.airbyte.com/platform/understanding-airbyte/airbyte-protocol-versioning)] However, in the provided sources there is no explicit statement that “to upgrade the platform past 0.63, all connectors must be on CDK version X or higher.” The documented constraint is: - Newer connectors (using newer CDK/protocol features) may require platform ≥ 0.63.7 (or another minimum), and the platform/bootloader prevents incompatible combinations. So: there has been a situation where connector versions/CDK features required a minimum platform version (notably around 0.63.7), but the knowledge sources do not confirm a blanket rule that upgrading the platform past 0.63 requires all connectors to be on a specific minimum CDK version.