Ronny Ritongadi

01/17/2022, 2:55 PM
Hi @Harshith (Airbyte), @Chris (deprecated profile) I'm running Airbyte 0.29.21-alpha, and it looks like the Airbyte is stuck at one particular error for all the connection to MySQL
2022-01-17 14:52:33 ERROR () LineGobbler(voidCall):85 - Exception in thread "main" java.sql.SQLSyntaxErrorException: SELECT command denied to user ''@'%' for column 'organizationId' in table 'IDX_PUTTOLIGHT'
(more complete log attached) I am very sure the DB user is having sufficient permission. Is it possible that Airbyte have stuck in one particular log causing every connection to error? Thank you, Ronny
This is the log
That response is coming back straight from your database so it likely isnt Airbyte doing this, but its weird that the username appears to be blank? Can you double check the connection has the username you want?
I thought so, but I've checked multiple times with the DB, and it should works The strange thing is this comes up after the connection is validated, and during schema refresh
Does your db have Views?
The fact that it fails during the schema discovery makes me think that^
yes have views, but the user is able to access the views
here is the screenshot during connection test
here is the error during schema discovery
it used to worked just fine, one day the database server were migrated, and we need to update the configuration with the new credential And I can't have it work since then

[DEPRECATED] Marcos Marx

01/18/2022, 12:12 AM
@Ronny Ritongadi probably is something with your MSSQL instance after the migration; also can you select the Replication Method in the Source Config to Standard?

Blake Enyart

01/18/2022, 1:47 AM
Hi @[DEPRECATED] Marcos Marx, MySQL replication method is already Standard, but still error not sure with MySQL instance, but the production application seems normal
Could you share what SQL command used when schema discovery? Or maybe turn on the log so I can see what command is being sent?
Hmm this is even strange, I can see the command: `SHOW FULL TABLES FROM `app`` when I tried with the same DB user in HeidiSQL, it returned successfully, but AirByte keep returning error .. any chance to clear the cache?
FINALLY WORKING! @Noah Kawasaki you lead me to the correct information, Thank You! I found one user that is the definer of some view deleted during migration, this can be seen with command
show table status;
I created the user and now its working properly