Hello! *Is this your first time deploying Airbyte...
# troubleshooting
Hello! Is this your first time deploying Airbyte: Yes OS Version / Instance: Ubuntu 21.10 Memory / Disk: 16Gb / 512GB Deployment: Docker Airbyte Version: 0.35.54-alpha Source name/version: Salesforce (sandbox) 1.0.2 Destination name/version: Snowflake 0.1.10 Step: On sync / normalization Description: I've set up my source and connexion successfully. When trying to sync (or refresh data, just in case) I get normalization errors (
2022-03-24 09:49:49 INFO i.a.v.j.JsonSchemaValidator(test):56 - JSON schema validation failed. errors: $.method: does not have a value in the enumeration [Standard]
). I even tried sending raw JSON but I get the same error. Anyone encountered this error? I always assumed salesforce to snowflake wouldn't quite be out-of-the-box but I'm a little lost as to how to fix this. Happy to provide logs if it can help.
Hi @Xavier Rosée, this errors happens because a record from the source does not comply with the stream schema that was created by the connector. Apparently, the connector does not handle well the salesforce
type. Could you please file a bug report on our repo, share your sync logs and if you can, get your salesforce object description from Salesforce API or support calling GET on:
Copy code
Here the problem is handling the type of your
field on your Salesforce object. The salesforce API return the
type but the connectors does not know the valid values for this enum type.