Jove Zhong
07/23/2023, 4:00 AMJove Zhong
07/23/2023, 4:00 AMCaused by: io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://172.20.0.1:443/api/v1/namespaces/user-jove/pods. Message: Pod "source-hubspot-read-255-2-nvfue" is invalid: spec.containers[0].resources.requests: Invalid value: "500m": must be less than or equal to cpu limit. Received status: Status(apiVersion=v1, code=422, details=StatusDetails(causes=[StatusCause(field=spec.containers[0].resources.requests, metadata=ListMeta(_continue=null, remainingItemCount=null, resourceVersion=null, selfLink=null, additionalProperties={}), reason=Invalid, status=Failure, additionalProperties={})
kapa.ai
07/23/2023, 4:01 AMJove Zhong
07/25/2023, 6:55 PMJove Zhong
07/26/2023, 3:44 PMkubectl logs airbyte-worker-78bb4744f6-db4ks -n user-jove and found this
2023-07-25 052007 INFO i.a.w.p.KubeProcessFactory(create):119 - Attempting to start pod = source-hubspot-read-259-0-whldo for airbyte/source-hubspot:1.1.0 with resources io.airbyte.config.ResourceRequirements@68f83f98[why cpuRequest is 0.5 while the cpuLimit is unset? I don't think I set this manually. More importantly, how to fix it? Should I update database or set env?,memoryRequest=,memoryLimit=,additionalProperties={}] and allowedHosts nullcpuRequest=0.5,cpuLimit=