I upgraded helm chart of airbyte from 0.45.35 to 0...
# replication-ask-ai
j
I upgraded helm chart of airbyte from 0.45.35 to 0.47.11 and keeps getting server error. Then I uninstall the chart and install again, the UI can be shown up for a few mins but cannot connect to the server from time to time. I tried to run a job to sync from hubspot and send to somewhere else, and got error "Invalid value: "500m": must be less than or equal to cpu limit." It worked in 0.45.35
full error message
Caused by: io.fabric8.kubernetes.client.KubernetesClientException: Failure executing: POST at: https://172.20.0.1:443/api/v1/namespaces/user-jove/pods. Message: Pod "source-hubspot-read-255-2-nvfue" is invalid: spec.containers[0].resources.requests: Invalid value: "500m": must be less than or equal to cpu limit. Received status: Status(apiVersion=v1, code=422, details=StatusDetails(causes=[StatusCause(field=spec.containers[0].resources.requests, metadata=ListMeta(_continue=null, remainingItemCount=null, resourceVersion=null, selfLink=null, additionalProperties={}), reason=Invalid, status=Failure, additionalProperties={})
k
New message text here
j
I cannot run any source connector in k8s deployment of 0.47.x. It seems that airbyte will try to run the source connector pod with wrong cpu request and limit (request 500m which is higher than cpu limit) I don't see this in the helm chart yml, maybe hardcode somewhere in the Java code. Can anyone look into this? or have similar issues? 🙏
I ran
kubectl logs airbyte-worker-78bb4744f6-db4ks -n user-jove
and found this
2023-07-25 052007 INFO i.a.w.p.KubeProcessFactory(create):119 - Attempting to start pod = source-hubspot-read-259-0-whldo for airbyte/source-hubspot:1.1.0 with resources io.airbyte.config.ResourceRequirements@68f83f98[
cpuRequest=0.5,cpuLimit=
,memoryRequest=,memoryLimit=,additionalProperties={}] and allowedHosts null
why cpuRequest is 0.5 while the cpuLimit is unset? I don't think I set this manually. More importantly, how to fix it? Should I update database or set env?