Has anyone encountered this issue when running Air...
# replication-ask-ai
g
Has anyone encountered this issue when running Airbyte 0.50.8 on GKE:
Copy code
io.airbyte.workers.exception.WorkerException: Failure executing: POST at: <https://10.76.0.1:443/api/v1/namespaces/default/pods>. Message: Unauthorized! Configured service account doesn't have access. Service account may have been revoked. Unauthorized.
We’re getting this sporadically after the pod has been running successfully for many hours and it’s resolved by deleting and redeploying the pod without any changes to associated roles. We’re running off the most recent Helm chart.
k
A message from kapa.ai
Hmm, I don't know enough to give you a confident answer yet. The information extracts provided do not contain specific details about the error you're encountering with Airbyte 0.50.8 on GKE. However, based on the error message, it seems like a permissions issue with the service account configured for your Kubernetes cluster. You might want to verify the permissions of your service account and ensure it has the necessary access rights. For more information on deploying Airbyte on Kubernetes, you can refer to the [official documentation](https://docs.airbyte.com/deploying-airbyte/on-kubernetes-via-helm).
u
@Conor Barber (Airbyte) would you be able to help here? I saw you tried before here but didn’t have an answer.
g
@Conor Barber (Airbyte) FYI, this is still an issue for me. I’ve taken to just deleting the worker pod and letting GKE redeploy it to re-authorize after a helm sync
c
Hello! I’ve been out of the office. This is a known issue with the helm charts. Compose team has mostly taken over maintenance of these, so I will shoot this over to @Malik Diarra
a
@Malik Diarra @Malik Diarra @Conor Barber (Airbyte) Any update on this issue? Every time I redeploy with
helm upgrade
without any changes to the serviceaccount I have to restart the pod manually:
kubectl rollout restart deployment -n airbyte airbyte-worker
👍 1
g
@Conor Barber (Airbyte) Have you seen this issue? Seems to provide a valid workaround with Kustomize and identifies the problem: https://github.com/airbytehq/airbyte/issues/18731