https://linen.dev logo
#ask-community-for-troubleshooting
Title
# ask-community-for-troubleshooting
s

sajan P

07/08/2021, 4:45 PM
root@airbyteone:/mnt/programs/airbyte# docker --version Docker version 20.10.7, build f0df350 root@airbyteone:/mnt/programs/airbyte# docker-compose up ERROR: Invalid interpolation format for "environment" option in service "scheduler": "AIRBYTE_ROLE=${AIRBYTE_ROLE:-}"
u

[DEPRECATED] Marcos Marx

07/08/2021, 6:24 PM
what version of docker-compose do you have?
s

sajan P

07/08/2021, 6:58 PM
root@airbyteone:/mnt/programs/airbyte# docker-compose --version docker-compose version 1.17.1, build unknown
u

[DEPRECATED] Marcos Marx

07/08/2021, 6:59 PM
could you upgrade to latest version?
s

sajan P

07/09/2021, 2:24 PM
it is the latest
docker-compose is already the newest version (1.17.1-2). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@airbyteone:/mnt/programs/airbyte# docker-compose version docker-compose version 1.17.1, build unknown docker-py version: 2.5.1 CPython version: 2.7.17 OpenSSL version: OpenSSL 1.1.1 11 Sep 2018
u

[DEPRECATED] Marcos Marx

07/09/2021, 5:08 PM
I'm on docker-compose 1.25.0, probably you need to upgrade your OS